Błędy w Excelu — krótkie omówienie #ADR! itd — widzowie #19

Jakie błędy pojawiają się w Excelu?


Błędy w Excelu — krótkie omówienie #ADR! itd — widzowie #19

Błędy w Excelu - krótkie omówienie #ADR! itd - widzowie #19

W Excelu jest 7 rodzajów błędów jakimi Excel Cię informuje o tym, że formuła nie może działać prawidłowo.

      #ZERO! — pojawia się gdy przy szukaniu przecięcia zakresy nie nachodzą na siebie (np: =E1:E7 F2:I2)
      #N/D! — brak wyszukiwanego elementu na liście (np: =WYSZUKAJ.PIONOWO(-1;E1:E3;1) w obszarze gdzie nie ma wartości mniejszej lub równej -1)
      #ADR! — formuła odwołuje się do adresy, który nie istnieje, najczęściej pojawia się gdy kopiujesz formułę do góry, załóżmy, że w komórce D4 masz SUMA(D1:D2) i kopiujesz o komórkę wyżej do D3 pojawia się błąd odwołania #ADR! ponieważ nie istnieje komórka D0, do której powinien się odwoływać Excel.
      #DZIEL/0! — Błąd dzielenia przez zero np: =1/0
      #NAZWA? — Błąd nazwy — Excel informuje Cię, że podana nazwa nie jest żadną funkcją, ani nazwanym zakresem lub tabelą (np: =dsdas)
      #ARG! — błąd argumentu, pojawia się gdy np: podajesz funkcji tekst, a ona oczekuje liczby (np: =SUMA(“DFAS”))
      #LICZBA! — przekroczyłeś zakres, dla którego Excel rozpoznaje liczby od -1 pomnożone przez 10 do potęgi 307 do 1pomnożone przez 10 do potęgi 307.

P.S.

Jeśli chcesz dowiedzieć się więcej na temat Excela lub nie wiesz jak coś zrobić do mnie o tym w komentarzu pod spodem albo napisz do mnie bezpośrednio, ja w miarę możliwości odpowiem na Twoje pytanie.

Excel i Adam - kontakt

Bezpośredni odnośnik do filmu na youtube — Błędy w Excelu — krótkie omówienie #ADR! itd — widzowie #19

Poprawne sumowanie zakresów z błędami dla różnych wersji Excela — widzowie #18

Jak sumować poprawnie mimo błędów w zakresie sumy?


Poprawne sumowanie zakresów z błędami dla różnych wersji Excela — widzowie #18

Poprawne sumowanie zakresów z błędami dla różnych wersji Excela - widzowie #18

Jeśli wykorzystujesz funkcję SUMA do sumowania zakresu, w którym jest błąd otrzymasz wynik z błędem. Jak tego uniknąć.

W Excelu 2010 możesz skorzystać z funkcji AGREGUJ np:

=AGREGUJ(9;6;B1:B8)

      9 (1 argument) — mówi, że chcesz sumować,
      6 (2 argument) — mówi, że funkcja ma ignorować błędy

Dla Excela 2007 formuła może wyglądać tak

=SUMA(JEŻELI.BŁĄD(B1:B9;0))

czyli sprawdza czy jest błąd (funkcja JEŻELI.BŁĄD), jeżeli jest to podstawiasz w jego miejsce zero, a potem sumujesz całość. Pamiętaj o zatwierdzeniu kombinacją klawiszy Ctrl + Shift + Enter, bo to formuła tablicowa.

Dla Excela 2003 jest najwięcej pisania:

=SUMA(JEŻELI(CZY.LICZBA(B1:B9);B1:B9;0))

Najpierw sprawdzasz czy wartość jest liczbą (funkcja CZY.LICZBA) jeśli tak to wstawiasz tą liczbę jeśli nie to wstawiasz zero (pomaga funkcja JEŻELI), a na koniec sumujesz. Tą formułę również zatwierdzasz kombinacją klawiszy Ctrl + Shift + Enter

Przy pliku .xls w jakim te formuły były pisane w trybie zgodności jeśli zechcesz zapisać plik pojawi Ci się komunikat o nie zgodności i możesz nawet podejrzeć raport i domyśleć się, że funkcja AGREGUJ jest dostępna od 2010, a JEŻELI.BŁĄD od 2007.

P.S.

Jeśli chcesz dowiedzieć się więcej na temat Excela lub nie wiesz jak coś zrobić do mnie o tym w komentarzu pod spodem albo napisz do mnie bezpośrednio, ja w miarę możliwości odpowiem na Twoje pytanie.

Excel i Adam - kontakt

Bezpośredni odnośnik do filmu na youtube — Poprawne sumowanie zakresów z błędami dla różnych wersji Excela — widzowie #18

Liczba porządkowa i filtrowane oraz ukryte wiersze — widzowie #17

Jak stawić liczbę porządkową nawet, gdy filtrujesz i ukrywasz wiersze?


Liczba porządkowa i filtrowane oraz ukryte wiersze — widzowie #17

Liczba porządkowa i filtrowane oraz ukryte wiersze - widzowie #17

Liczbę porządkową możesz łatwo zrobić korzystając z możliwości tworzenie ciągów jakie daje Ci Excel, ale co w sytuacji, gdy chcesz, żeby liczba porządkowa dopasowywała się do ilość wyświetlanych wierszy, czyli nie liczyła wierszy ukrytych i przefiltrowanych.

Taki właśnie miała problem Renata. Okazuje się, że jej problem rozwiązana funkcja SUMY.CZĘŚCIOWE z rozrastającym się zakresem, czyli taki, który początek ma stały o koniec przesuwa się wraz z formułą np: $B$2:B2

Ważne, że funkcja SUMY.CZĘŚCIOWE ma dwie serie funkcji z numerami od 1 do 11 i od 101 do 111. Mniejsze numery biorą pod uwagę ukryte i widoczne wiersze, ale nie liczą przefiltrowanym, a z większymi numerami (powyżej 100) liczą tylko widoczne wiersze (nie liczą ukrytych wierszy i przefiltrowanych).

Przykładowa funkcja może wyglądać tak:

=SUMY.CZĘŚCIOWE(103;$B$2:B2)

liczy ona tylko widoczne niepuste komórki.

Trzeba jeszcze uważać z filtrami przy takim zapisie, bo Excel automatycznie traktuje ostatni wiersz z funkcją SUMY.CZĘŚCIOWE jako wiersz podsumuwujący i nie bierze pod uwagę przy filtrach, czyli ten wiersz będzie zawsze widoczny, dlatego warto zrobić pod koniec jeszcze jedno podumowanie np: wyników sprzedaży.

P.S.

Jeśli chcesz dowiedzieć się więcej na temat Excela lub nie wiesz jak coś zrobić do mnie o tym w komentarzu pod spodem albo napisz do mnie bezpośrednio, ja w miarę możliwości odpowiem na Twoje pytanie.

Excel i Adam - kontakt

Bezpośredni odnośnik do filmu na youtube — Liczba porządkowa i filtrowane oraz ukryte wiersze — widzowie #17

Nazwy dni tygodnia z daty w 10 sekund — porada #80

Jak wstawić nazwę dnia tygodnia z daty w 10 sekund?


Nazwy dni tygodnia z daty w 10 sekund — porada #80

Nazwy dni tygodnia z daty w 10 sekund - porada #80

Demluk w komentarzu do porady #79 zwrócił mi uwagę, że przekombinowałem z formułą do wyciągania nazwy dnia tygodnia z daty. Zamiast skomplikowanej formuły, którą zaproponowałem wystarczy 1 funkcja:

=TEKST(B2;“dddd”)

I masz wstawioną pełną nazwę dnia tygodnia. W zależności ile “d” użyjesz w 2 argumencie uzyskasz różne wyniki

      “dddd” — pełna nazwa dnia tygodnia
      “ddd” — skrócona nazwa dnia tygodnia
      “dd” — numer dnia w miesiącu z dopełniającym zerem na początku dla dni jednocyfrowych np: 01
      “d” — numer dnia w miesiącu bez dopełnień np: 7

P.S.

Jeśli chcesz dowiedzieć się więcej na temat Excela lub nie wiesz jak coś zrobić napisz do mnie o tym w komentarzu pod spodem albo bezpośrednio. W miarę możliwości odpowiem na Twoje pytanie.

Excel i Adam - kontakt

Bezpośredni odnośnik do filmu na youtube — Nazwy dni tygodnia z daty w 10 sekund — porada #80

Nazwy dni tygodnia dopasowane do daty — porada #79

Jak przy datach ustawić nazwę dnia tygodnia?


Nazwy dni tygodnia dopasowane do daty — porada #79

Nazwy dni tygodnia dopasowane do daty - porada #79
Co masz zrobić, gdy chcesz obok daty napisać jaki to jest dzień tygodnia, czyli np:

2013-11-08 to piątek

Cóż możesz zerknąć w kalendarz i wpisać odpowiednią nazwę dnia tygodnia, a jeśli masz więcej nazw w kolumnie to wystarczy, że klikniesz 2 razy w prawy dolny róg komórki i Excel wypełni ciągiem nazwy dni tygodnia od poniedziałku do niedzieli cykliczne.

Jeśli jednak zmienisz daty, znów będziesz musiał poprawiać nazwę dnia tygodnia. To może być jeszcze trudniejsze, jeśli nie masz dni ustawionych po kolei — wtedy ta takty wcale się nie sprawdzi (zapomniałem o tym wspomnieć w wideo).

Żeby to zrobić za pomocą formuły, która się automatycznie dostosowuje musisz wykorzystać funkcję DZIEŃ.TYG i tu pojawia się mały problem, bo ta funkcja nie zwraca nazwy dnia tygodnia tylko jego numer i w zależności od Twoich potrzeb te numery mogą oznaczać różne dni tygodnia (kwestia wybrania odpowiedniego 2 argumentu), dlatego potrzebna Ci tabela pomocnicza, gdzie będziesz miał przypisane numery do nazw dni tygodnia i funkcja WYSZUKAJ.PIONOWO.

Czyli najpierw funkcja DZIEŃ.TYG podaje Ci numer dnia, a potem za pomocą funkcji WYSZUKAJ.PIONOWO wyszukujesz odpowiednią nazwę z tabeli pomocniczej.

=WYSZUKAJ.PIONOWO(DZIEŃ.TYG(B2;2);$D$6:$E$12;2)

i to załatwia sprawę nawet jeśli masz nieuporządkowane dni, ale ciąg z przerwami albo często zmieniasz daty.

P.S.

Jeśli chcesz dowiedzieć się więcej na temat Excela lub nie wiesz jak coś zrobić napisz do mnie o tym w komentarzu pod spodem albo bezpośrednio. W miarę możliwości odpowiem na Twoje pytanie.

Excel i Adam - kontakt

Bezpośredni odnośnik do filmu na youtube — Nazwy dni tygodnia dopasowane do daty — porada #79