Jak sumować poprawnie mimo błędów w zakresie sumy?


Poprawne sumowanie zakresów z błędami dla różnych wersji Excela — widzowie #18

Poprawne sumowanie zakresów z błędami dla różnych wersji Excela - widzowie #18

Jeśli wykorzystujesz funkcję SUMA do sumowania zakresu, w którym jest błąd otrzymasz wynik z błędem. Jak tego uniknąć.

W Excelu 2010 możesz skorzystać z funkcji AGREGUJ np:

=AGREGUJ(9;6;B1:B8)

      9 (1 argument) — mówi, że chcesz sumować,
      6 (2 argument) — mówi, że funkcja ma ignorować błędy

Dla Excela 2007 formuła może wyglądać tak

=SUMA(JEŻELI.BŁĄD(B1:B9;0))

czyli sprawdza czy jest błąd (funkcja JEŻELI.BŁĄD), jeżeli jest to podstawiasz w jego miejsce zero, a potem sumujesz całość. Pamiętaj o zatwierdzeniu kombinacją klawiszy Ctrl + Shift + Enter, bo to formuła tablicowa.

Dla Excela 2003 jest najwięcej pisania:

=SUMA(JEŻELI(CZY.LICZBA(B1:B9);B1:B9;0))

Najpierw sprawdzasz czy wartość jest liczbą (funkcja CZY.LICZBA) jeśli tak to wstawiasz tą liczbę jeśli nie to wstawiasz zero (pomaga funkcja JEŻELI), a na koniec sumujesz. Tą formułę również zatwierdzasz kombinacją klawiszy Ctrl + Shift + Enter

Przy pliku .xls w jakim te formuły były pisane w trybie zgodności jeśli zechcesz zapisać plik pojawi Ci się komunikat o nie zgodności i możesz nawet podejrzeć raport i domyśleć się, że funkcja AGREGUJ jest dostępna od 2010, a JEŻELI.BŁĄD od 2007.

P.S.

Jeśli chcesz dowiedzieć się więcej na temat Excela lub nie wiesz jak coś zrobić do mnie o tym w komentarzu pod spodem albo napisz do mnie bezpośrednio, ja w miarę możliwości odpowiem na Twoje pytanie.

Excel i Adam - kontakt

Bezpośredni odnośnik do filmu na youtube — Poprawne sumowanie zakresów z błędami dla różnych wersji Excela — widzowie #18