Wykres stanu wód umiejętne wykorzystanie znaczników — widzowie #46

Jak stworzyć wykres wykorzystujący znaczniki?


Wykres stanu wód umiejętne wykorzystanie znaczników — widzowie #46

Wykres stanu wód umiejętne wykorzystanie znaczników - widzowie #46

Na wykresie liniowym znaczniki mogą być bardzo przydatne. Można np: usunąć linie z wykresu i zostawić same znaczniki. Będzie wtedy wyglądało jakby każdy znacznik był punktem wysokościowym.

Można to łączyć dodatkowo z pomocniczym wykresem kolumnowym, i liniami maks-min i wychodzi ciekawy wykres.

P.S.

Jeśli chcesz dowiedzieć się więcej na temat Excela lub nie wiesz jak coś zrobić to napisz do mnie. Ja w miarę możliwości odpowiem na Twoje pytanie.

Excel i Adam - kontakt

Bezpośredni odnośnik do filmu na youtube — Wykres stanu wód umiejętne wykorzystanie znaczników — widzowie #46

Zamiana tekstu z przecinkami na liczby PODSTAW — widzowie #45

Jak zamienić liczbę w formacie tekstowym z przecinkami na poprawną liczbę?


Zamiana tekstu z przecinkami na liczby PODSTAW — widzowie #45

Zamiana tekstu z przecinkami na liczby PODSTAW - widzowie #45

Jak zamienić tekst na liczbę? Jeśli jest to liczba w formacie tekstowym to wystarczy wykonać dowolną operację matematyczną np: dodać zero. Jeśli tak jak w omawianym tu przykładzie, gdzie mogą się pojawić przecinki, które rozdzielają tysiące
1,743,59
94,949,58
1 555,88
ale nie muszą sprawa staje się bardziej skomplikowana.

Ponieważ to zawsze są przecinki możemy je zamienić na pusty ciąg znaków za pomocą funkcji PODSTAW, dodatkowo założymy, że mają też pełną część dziesiętną

=PODSTAW(A2;”,”;””)/100

niestety to nie rozwiązuje wszystkich sytuacji, bo pojawiają się liczby, które nie mają części dziesiętnej i musimy obsłużyć sytuację, gdy liczba nie ma miejsc dziesiętnych. Najłatwiej to zrobić sprawdzając, czy 3 znak od prawej strony to przecinek, pomoże nam w tym funkcja FRAGMENT.TEKSTU:

=JEŻELI(FRAGMENT.TEKSTU(A2;DŁ(A2)-2;1)=”,”;PODSTAW(A2;”,”;””)/100;PODSTAW(A2;”,”;””)+0)

Zostaje na tu do dołożenia jeszcze tylko sytuacja, gdy nie ma miejsc dziesiętnych i jest mniejsza od stu, czyli funkcja FRAGMENT.TEKSTU będzie próbowała pobrać nieistniejący znak. To wystarczy sprawdzić, czy liczba znaków jest większa od 2 za pomocą funkcji Cała formuła będzie wyglądać tak:

=JEŻELI(DŁ(A2) większe niż 2;JEŻELI(FRAGMENT.TEKSTU(A2;DŁ(A2)-2;1)=”,”;PODSTAW(A2;”,”;””)/100;PODSTAW(A2;”,”;””)+0);A2+0)

P.S.

Jeśli chcesz dowiedzieć się więcej na temat Excela lub nie wiesz jak coś zrobić to napisz do mnie. Ja w miarę możliwości odpowiem na Twoje pytanie.

Excel i Adam - kontakt

Bezpośredni odnośnik do filmu na youtube — Zamiana tekstu z przecinkami na liczby PODSTAW — widzowie #45