Numer konta bankowego poprawnie oraz NIP i kod pocztowy — porada #78

Jak zapisać poprawnie numer konta bankowego oraz NIP i kod pocztowy w Excelu?


Numer konta bankowego poprawnie oraz NIP i kod pocztowy — porada #78

Numer konta bankowego poprawnie oraz NIP i kod pocztowy - porada #78

Jeśli wpiszesz zwyczajnie numer kontra bankowego do komórki w Excelu, otrzymasz liczbę zapisaną w dziwny (dla większości ludzi) naukowy sposób. Żeby zapisać najprostszym rozwiązaniem jest na początku numeru kodu postawić znak pojedynczego cudzysłowa '

Da to znać Excelowi, że wszystko co nastąpi po tym znaku ma traktować jako tekst, a samego znaku ma nie wyświetlać. Co prawda numer konta bankowego będzie traktowany jako tekst i operacje matematyczne na nim będą utrudnione, ale ja nie spotkałem sytuacji by było to potrzebne, a Ty?

Z numerem NIP i kodem pocztowym sprawa jest prostsza bo przeważnie pisze się je z myślnikiem co automatycznie powoduje, że Excel traktuje jako tekst (wyrównanie do lewej).

Jeśli jednak chcesz, żeby Excel NIP i kod pocztowy traktował jako liczbę (wyrównanie do prawej) możesz to uzyskać stosując formatowanie Specjalne. Po naciśnięciu Ctrl + 1 otworzy Ci się okno formatowania komórek, gdzie w zakładce Liczby znajdziesz właśnie formatowania specjalne m.in. NIPu i kodu pocztowego. Excel sam dostawi Ci myślniki w odpowiednie miejsca i będzie traktował te wartości jako liczby (np: w pasku formuły będziesz widział samą liczbę bez myślników).

P.S.

Jeśli chcesz dowiedzieć się więcej na temat Excela lub nie wiesz jak coś zrobić napisz do mnie o tym w komentarzu pod spodem albo bezpośrednio. W miarę możliwości odpowiem na Twoje pytanie.

Excel i Adam - kontakt

Bezpośredni odnośnik do filmu na youtube — Numer konta bankowego poprawnie oraz NIP i kod pocztowy — porada #78

Podliczanie godzin pracy w miesiącu łącznie z płatnymi dniami wolnymi — widzowie #16

Jak podliczyć godziny pracy w miesiącu łącznie z płatnymi dniami wolnymi?


Podliczanie godzin pracy w miesiącu łącznie z płatnymi dniami wolnymi — widzowie #16

Podliczanie godzin pracy w miesiącu łącznie z płatnymi dniami wolnymi - widzowie #16

Podliczanie godzin pracy w miesiącu jest bardzo proste jeśli liczysz tylko ilość przepracowanych godzin — wystarczy funkcja SUMA. Problem pojawia się, gdy chcesz jeszcze uwzględnić dni wolne od pracy, za które pracownikowi należy się pełna dniówka (8 godzin) pensji.

Artur postanowił oznaczyć taki dzień w podliczeniu literą W, czyli wystarczy, że zliczysz wystąpienia W w miesiącu za pomocą funkcji LICZ.JEŻELI, pomnożysz przez 8 i dodasz do pozostałych godzin i masz łączną ilość płatnych godzin.

Okazuje się, że jest to bardzo proste m.in. dlatego, że funkcja SUMA w Excelu ignoruje tekst, dlatego przepracowane godziny i dni wolne mogą być w jednej kolumnie, a na koniec jej zrobić podsumowanie zapisując formułę:

=SUMA(C2:C32)+LICZ.JEŻELI(C2:C32;"W")*8

P.S.

Jeśli chcesz dowiedzieć się więcej na temat Excela lub nie wiesz jak coś zrobić do mnie o tym w komentarzu pod spodem albo napisz do mnie bezpośrednio, ja w miarę możliwości odpowiem na Twoje pytanie.

Excel i Adam - kontakt

Bezpośredni odnośnik do filmu na youtube — Podliczanie godzin pracy w miesiącu łącznie z płatnymi dniami wolnymi — widzowie #16

Dodawanie metrów kwadratowych — 2 sposoby — widzowie #15

Jak dodać metry kwadratowe poprawnie w Excelu?


Dodawanie metrów kwadratowych — 2 sposoby — widzowie #15

Dodawanie metrów kwadratowych - 2 sposoby - widzowie #15

Jak dodać metry kwadratowe (m2) w Excelu? W tym wideo znajdziesz 2 rozwiązanie.

Pierwsze przy założeniu w sytuacji gdy metry kwadratowe są zapisane jako tekst 12,3 m² i trzeba się bardzie napocić, żeby wyciągnąć wartości liczbowe. Należy najpierw wyciągnąć funkcją LEWY wartość liczbową mniejszą o 2 ostatnie znaki (przyda się funkcja DŁ można to zrobić w osobnej kolumnie i formuły będę wyglądać tak:

=LEWY(B1;DŁ(B1)-2)+0

Na końcu formuły dodajesz zero, ponieważ funkcja LEWY zwraca tekst, którego nie da się sumować, a dodanie zera zapewnia konwersję na liczbę.

Po tym wystarczy funkcja SUMA do zsumowania wyniku.

Żeby zrobić te obliczenia w 1 komórce trzeba wykorzystać formuły tablicowe:

{=SUMA(LEWY(B1:B2;DŁ(B1:B2)-2)+0)&" m2"}

trzeba zatwierdzić kombinacją klawiszy Ctrl + Shift + Enter. Można to obejść korzystając z funkcji SUMA.ILOCZYNÓW, która radzi sobie z formułami tablicowymi, bez zatwierdzania specjalnym ciągiem klawiszy

=SUMA.ILOCZYNÓW(LEWY(B1:B2;DŁ(B1:B2)-2)+0)&" m2"

Drugie rozwiązanie wykorzystuje formatowanie niestandardowe np:

0,00"m2"

dzięki temu obok wartości liczbowych pojawi się symbol metrów kwadratowych (m2), ale nie będzie ich rzeczywiście w komórce i Excel będzie te komórki traktował jako liczba i będzie je można zsumować funkcją SUMA.

=SUMA(F1:F2)

P.S.

Jeśli chcesz dowiedzieć się więcej na temat Excela lub nie wiesz jak coś zrobić do mnie o tym w komentarzu pod spodem albo napisz do mnie bezpośrednio, ja w miarę możliwości odpowiem na Twoje pytanie.

Excel i Adam - kontakt

Bezpośredni odnośnik do filmu na youtube — Dodawanie metrów kwadratowych — 2 sposoby — widzowie #15