Jak przy datach ustawić nazwę dnia tygodnia?


Nazwy dni tygodnia dopasowane do daty — porada #79

Nazwy dni tygodnia dopasowane do daty - porada #79
Co masz zrobić, gdy chcesz obok daty napisać jaki to jest dzień tygodnia, czyli np:

2013-11-08 to piątek

Cóż możesz zerknąć w kalendarz i wpisać odpowiednią nazwę dnia tygodnia, a jeśli masz więcej nazw w kolumnie to wystarczy, że klikniesz 2 razy w prawy dolny róg komórki i Excel wypełni ciągiem nazwy dni tygodnia od poniedziałku do niedzieli cykliczne.

Jeśli jednak zmienisz daty, znów będziesz musiał poprawiać nazwę dnia tygodnia. To może być jeszcze trudniejsze, jeśli nie masz dni ustawionych po kolei — wtedy ta takty wcale się nie sprawdzi (zapomniałem o tym wspomnieć w wideo).

Żeby to zrobić za pomocą formuły, która się automatycznie dostosowuje musisz wykorzystać funkcję DZIEŃ.TYG i tu pojawia się mały problem, bo ta funkcja nie zwraca nazwy dnia tygodnia tylko jego numer i w zależności od Twoich potrzeb te numery mogą oznaczać różne dni tygodnia (kwestia wybrania odpowiedniego 2 argumentu), dlatego potrzebna Ci tabela pomocnicza, gdzie będziesz miał przypisane numery do nazw dni tygodnia i funkcja WYSZUKAJ.PIONOWO.

Czyli najpierw funkcja DZIEŃ.TYG podaje Ci numer dnia, a potem za pomocą funkcji WYSZUKAJ.PIONOWO wyszukujesz odpowiednią nazwę z tabeli pomocniczej.

=WYSZUKAJ.PIONOWO(DZIEŃ.TYG(B2;2);$D$6:$E$12;2)

i to załatwia sprawę nawet jeśli masz nieuporządkowane dni, ale ciąg z przerwami albo często zmieniasz daty.

P.S.

Jeśli chcesz dowiedzieć się więcej na temat Excela lub nie wiesz jak coś zrobić napisz do mnie o tym w komentarzu pod spodem albo bezpośrednio. W miarę możliwości odpowiem na Twoje pytanie.

Excel i Adam - kontakt

Bezpośredni odnośnik do filmu na youtube — Nazwy dni tygodnia dopasowane do daty — porada #79