Tym razem do wyszukiwania z uwzględnieniem wielkości liter wykorzystamy inne funkcje niż WYSZUKAJ.PIONOWO. Rozpatrzymy dwa rozwiązania. Oba będą wykorzystały wynik funkcji PORÓWNAJ:

=PORÓWNAJ(E2;$A$2:$A$11)

Widzowie 95 - Jak wyszukiwać z uwzględnieniem wielkości liter różne funkcje 01

Tak jak w poprzednich wpisach wynikiem będzie tablica wartości logicznych PRAWDA i FAŁSZ. PRAWDA, będzie w tych komórkach, gdzie ciągi tekstowe były identyczne w pozostałych będzie FAŁSZ.

Widzowie 95 - Jak wyszukiwać z uwzględnieniem wielkości liter różne funkcje 02

Pierwsza formuła będzie jeszcze korzystać z funkcji PODAJ.POZYCJĘ oraz INDEKS. Za pomocą funkcji PODAJ.POZYCJĘ odnajdziesz wartość PRAWDA w wynikach funkcji PORÓWNAJ:

=PODAJ.POZYCJĘ(PRAWDA;PORÓWNAJ(F2;$A$2:$A$11);0)

Widzowie 95 - Jak wyszukiwać z uwzględnieniem wielkości liter różne funkcje 03

A jak masz już pozycję prawdy, to wystarczy skorzystać z funkcji INDEKS, gdzie jako pierwszy argument wstawisz zakres kolumny, z której chcesz wyciągnąć wartość:

=INDEKS($C$2:$C$11;PODAJ.POZYCJĘ(PRAWDA;PORÓWNAJ(F2;$A$2:$A$11);0))

Widzowie 95 - Jak wyszukiwać z uwzględnieniem wielkości liter różne funkcje 04

Pamiętaj tylko zatwierdzić formułę jako formułę tablicową – kombinacją klawiszy Ctrl + Shift + Enter.

Drugie rozwiązanie będzie wykorzystywało funkcję WYSZUKAJ. Tylko standardowo musisz odpowiednio przygotować dane, żeby z niej skorzystać. Tym razem wynik funkcji PORÓWNAJ posłuży jako dzielnik. Wystarczy, że wartość 1 podzielisz przez wynik funkcji PORÓWNAJ:

=1/PORÓWNAJ(F2;$A$2:$A$11)

Ponieważ w Excelu jeśli wykonasz dowolną operację matematyczną na wartościach logicznych PRAWDA lub FAŁSZ, to Excel zamieni je odpowiednio na liczby 1 i 0. To wynikiem takiego dzielenia, będzie tablica błędów dzielenia przez zero i liczby 1 (dla PRAWDA):

Widzowie 95 - Jak wyszukiwać z uwzględnieniem wielkości liter różne funkcje 05

Teraz już możesz obudować naszą tablicę z wynikami funkcją WYSZUKAJ. Będziesz szukał liczby 2, ponieważ funkcja WYSZUKAJ zawsze działa na zasadzie dopasowania przybliżonego, dlatego jeśli karzesz jej szukać 2 w tablicy 1 i błędów dzielenia przez zero (#DZIEL/0!), to Excel znajdzie ostatnią liczbę 1. (Odwrotnie jak w pierwszej formule, która znajduje pierwsze wystąpienie szukanej wartości).

Potrzeba jeszcze tylko podać argument wektor_wynikowy, czyli analogicznie jak w funkcji INDEKS kolumnę, z której chcesz wyciągnąć wartość:

=WYSZUKAJ(2;1/PORÓWNAJ(F2;$A$2:$A$11);$C$2:$C$11)

Widzowie 95 - Jak wyszukiwać z uwzględnieniem wielkości liter różne funkcje 06

To rozwiązanie fajne jest dlatego, gdyż nie wymaga zatwierdzania specjalna kombinacją klawiszy.

Odpowiednio wyniki dla dwóch zaprezentowanych formuł będą się różnić ze względu na ilość występujących tekstów i ich pozycje:

Widzowie 95 - Jak wyszukiwać z uwzględnieniem wielkości liter różne funkcje 07
Pozdrawiam
Adam Kopeć
Miłośnik Excela