Jeśli zależy Ci żeby wyszukiwać uwzględniając wielkość liter to musisz przygotować odpowiednią formułę. Dzięki komentarzowi Patryka Murowskiego pod wideo „Widzowie 93” poznałem prostszą formułę niż tą, którą znałem. Wykorzystuje m.in. funkcję WYSZUKAJ.PIONOWO. Będziemy działać na przykładowych danych:

Widzowie 94 - Jak wyszukiwać z uwzględnieniem wielkości liter WYSZUKAJ.PIONOWO prostsze 01

Nasz obliczenia zaczniemy od funkcji PORÓWNAJ, która porównuje dwa ciągi tekstowe (uwzględniając wielkość liter) i w zależności od wyniku porównania zwraca wartość logiczną PRAWDA albo FAŁSZ. W naszym przykładzie potrzebujemy, jako jeden z argumentów funkcji PORÓWNAJ podać tekst, którego szukamy, a jako drugi odwołanie do kolumny, którą będziemy przeszukiwać:

=PORÓWNAJ(F2;$A$2:$A$11)

Widzowie 94 - Jak wyszukiwać z uwzględnieniem wielkości liter WYSZUKAJ.PIONOWO prostsze 02

Przy takich danych funkcja PORÓWNAJ zwróci tablicę wartości logicznych PRAWDA i FAŁSZ. PRAWDA, będzie w tych komórkach, gdzie ciągi tekstowe były identyczne w pozostałych będzie FAŁSZ.

Widzowie 94 - Jak wyszukiwać z uwzględnieniem wielkości liter WYSZUKAJ.PIONOWO prostsze 03

Teraz na podstawie wyników funkcji PORÓWNAJ stworzymy tablicę, po której będzie szukała funkcja WYSZUKAJ.PIONOWO. Wystarczy, że skorzystasz z funkcji JEŻELI, dla której tablica wartości logicznych PRAWDA i FAŁSZ będą argumentem test_logiczny. Gdy funkcja PORÓWNAJ będzie zwracała PRAWDĘ będziemy chcieli, żeby pokazywał się wiersz z danymi. To bardzo łatwo da się uzyskać, bo wystarczy podać zakres danych jako argument wartość_jeżeli_prawda. Natomiast argument wartość_jeżeli_fałsz możesz całkowicie pominąć, ponieważ domyślnie będzie zamiast niego zwracana wartość FAŁSZ.

=JEŻELI(PORÓWNAJ(F2;$A$2:$A$11);$A$2:$C$11)

Widzowie 94 - Jak wyszukiwać z uwzględnieniem wielkości liter WYSZUKAJ.PIONOWO prostsze 04

Jeżeli podejrzysz wynik funkcji JEŻELI klawiszem F9, to zobaczysz, że zwracany jest wiersz danych tylko jeśli został znaleziony identyczny tekst. W innych sytuacjach są zwracane wiersze wartości FAŁSZ.

Widzowie 94 - Jak wyszukiwać z uwzględnieniem wielkości liter WYSZUKAJ.PIONOWO prostsze 05

To pasuje idealnie do obliczeń, bo wystarczy, że wstawisz formułę do funkcji WYSZUKAJ.PIONOWO, która będzie szukała danego słowa, ponieważ tylko ona, lub wartość FAŁSZ jest w pierwszej kolumnie przeszukiwanej tablicy danych. Wystarczy jeszcze dopisać, że chcesz wyciągnąć wartość z 3 kolumny i dokonywać przeszukiwania na zasadzie dokładnej (czwarty argument = 0).

=WYSZUKAJ.PIONOWO(F2;JEŻELI(PORÓWNAJ(F2;$A$2:$A$11);$A$2:$C$11);3;0)

Widzowie 94 - Jak wyszukiwać z uwzględnieniem wielkości liter WYSZUKAJ.PIONOWO prostsze 06

Pamiętaj tylko zatwierdzić formułę jako formułę tablicową – kombinacją klawiszy Ctrl + Shift + Enter.
Pozdrawiam
Adam Kopeć
Miłośnik Excela