Jak stworzyć wykres demograficzny w Excelu?


Wykres prędkościomierza — porada #88

Wykres prędkościomierza - porada #88

Zajmijmy się wykresem prędkościomierzu. Gdy masz przygotowane odpowiednie dane. podzielone na 2 części. 1 część odpowiada za miernik, a 2 za wskaźnik.

Zaznaczamy 1 część i tworzymy na jej podstawie wykres pierścieniowy. Dane zostały tak przygotowane, że potrzebujemy przekręcić wykres o 270 stopni, a następnie część nazwaną w danych Koniec wypełnić brakiem wypełnienia, a pozostałe części według wcześniejszych ustaleń (czerwony, żółty, zielony).

Teraz potrzebujemy dodać 2 część wykresu wskaźnik. Korzystamy z opcji z karty Projektowanie z Narzędzi wykresów i wybieramy opcję Zaznacz dane.

Następnie naciskamy guzik Dodaj dla Serii danych i zaznaczamy odpowiednie dane liczbowe.

Dodał nam się drugi wykres pierścieniowy na zewnątrz pierwszego. Potrzebujemy go teraz zaznaczyć i zamienić na wykres kołowy (karta Projektowanie — Narzędzia wykresów).

Po zmianie musimy go znowu obrócić o 270 stopni i ustawić wypełnienie na brak wypełnienia dla 2 większych kawałków wykresu, a najmniejszy wypełnić Wypełnieniem pełnym np: kolorem czarnym.

Jeśli wykres kołowy jest pod pierścieniem należy ustawić go jako Oś pomocniczą w jego formatowaniu (zaznaczyć i nacisnąć Ctrl + 1).

Teraz jeszcze chcemy ustawić etykietę dla wskaźnika jako wartość. Zaznaczamy tylko ten mały kawałek (jeśli nie trafiasz myszką to wykorzystaj strzałki na klawiaturze, żeby przejść do tego elementu) naciskamy prawy przycisk myszy i wybieramy opcję Dodaj etykietę danych. Jest drobny problem bo pokazuje wartość 1, a my chcemy, żeby pokazywała się wartość określona w filmie jako Wartość.

Żeby to zrobić trzeba kliknąć w etykietę, a następnie w pasek formuły napisać = a następnie kliknąć na komórkę przechowującą odpowiednią wartość.

Teraz gdy zmienimy tą wartość, to odpowiednio przestawi się wskaźnik i zmieni wartość etykiety.

Ustawione tu parametry pozwalają Ci przedstawić wartości od 0 do 100, ale jeśli chcesz większe wartości to wystarczy odpowiednio ustawić parametry w pierwszej serii danych. Ważne, żeby część oznaczona Koniec była równa sumie pozostałych 3 oznaczonych (czerwony, żółty, zielony).

Wartości w drugiej serii dopasowują się odpowiednio dzięki ustawieniu formuły:

=SUMA(B2:B6)-SUMA(E2:E3)

w komórce oznaczonej koniec. Dzięki temu oba koła mają taką samą ilość punktów przypadających na 360 stopni i prędkościomierz ustawiony jest w górnej połowie.

P.S.

Jeśli chcesz dowiedzieć się więcej na temat Excela lub nie wiesz jak coś zrobić napisz do mnie o tym w komentarzu pod spodem albo bezpośrednio. W miarę możliwości odpowiem na Twoje pytanie.

Excel i Adam - kontakt

Bezpośredni odnośnik do filmu na youtube — Wykres prędkościomierza — porada #88