Jak stworzyć tabelę pomocniczą, która będzie wyciągać automatycznie dane z tabeli głównej na podstawie kryterium?


Automatyczna tabela pomocniczej z tabeli głównej z dynamicznym kryterium — widzowie #26

Automatyczna tabela pomocniczej z tabeli głównej z dynamicznym kryterium - widzowie #26

W filmie Excel — Automatyczne wypełniana tabela pomocniczej z tabeli głównej z 1 kryterium — widzowie #25

wykorzystaliśmy formułę do pobierania danych z tabeli głównej do tabeli pomocniczej przy założeniu 1 kryterium

=JEŻELI.BŁĄD(INDEKS(Tabela13[#Dane];MIN.K(JEŻELI($A$5:$A$20=$G$2;WIERSZ(Fabryka)-WIERSZ($A$5)+1);ILE.WIERSZY($F$5:$F5));LICZBA.KOLUMN($A$5:A$5));"")

a co w sytuacji gdy chcemy, żeby nasze kryterium było dynamiczne?

Potrzebujemy zmodyfikować test logiczny w funkcji JEŻELI $A$5:$A$20=$G$2
tak, żeby przesuwał się po kolumnach tabeli głównej w zależności od kryterium jakie wybierzemy.

Nowy test logiczny będzie wyglądał tak:

PRZESUNIĘCIE($A$5:$A$20;0;PODAJ.POZYCJĘ($G$1;Tabela1[#Nagłówki];0)-1)=$G$2

wykorzystujemy funkcję PRZESUNIĘCIE do przesuwania się od pierwszej kolumny ($A$5:$A$20).
Drugi parametr (0) mówi nam, że nie chcemy się ruszać z pozycji startowej jeśli chodzi o wiersze.

Trzeci parametr (PODAJ.POZYCJĘ($G$1;Tabela1[#Nagłówki];0)-1) podaje nam o ile kolumn chcemy się przesunąć w zależności od rodzaju kryterium (nagłówka, dla którego ustaliliśmy kryterium).
Po prostu szukamy, go, a właściwie jego pozycji w nagłówkach tabeli. Potrzebujemy tutaj funkcji PODAJ.POZYCJĘ i przeszukiwania dokładnego.
Ważne, że od wyniku funkcji PODAJ.POZYCJĘ potrzebujemy odjęć jedynkę ponieważ, jeśli kryterium jest z 1 kolumny nie chcemy się przesuwać (0 kolumn), jeśli z 2 kolumny to chcemy się przesunąć o 1 kolumnę itd.

Po skorygowaniu formuły wygląda ona tak:

=JEŻELI.BŁĄD(INDEKS(Tabela1;MIN.K(JEŻELI(PRZESUNIĘCIE($A$5:$A$21;0;PODAJ.POZYCJĘ($G$1;Tabela1[#Nagłówki];0)-1)=$G$2;WIERSZ($C$5:$C$21)-WIERSZ($A$5)+1);ILE.WIERSZY($F$5:$F5));LICZBA.KOLUMN($A$5:A$5));"")

i w zależności od dynamicznego kryterium daje odpowiednie wyniki.

Do stworzenia dynamicznego kryterium przydadzą Ci się informacje z filmów:

Dynamiczna zmiana listy rozwijanej na podstawie innej listy — porada #83

Wyszukanie unikalnych nazw do dynamicznej listy rozwijanej z walidacją danych — sztuczki #47

P.S.

Jeśli chcesz dowiedzieć się więcej na temat Excela lub nie wiesz jak coś zrobić do mnie o tym w komentarzu pod spodem albo napisz do mnie bezpośrednio, ja w miarę możliwości odpowiem na Twoje pytanie.

Excel i Adam - kontakt

Bezpośredni odnośnik do filmu na youtube — Automatyczna tabela pomocniczej z tabeli głównej z dynamicznym kryterium — widzowie #26