Jak stworzyć tabelę pomocniczą, która będzie wyciągać automatycznie dane z tabeli głównej na podstawie kryterium?


Automatyczne wypełniana tabela pomocniczej z tabeli głównej z 1 kryterium — widzowie #25

WAutomatyczne wypełniana tabela pomocniczej z tabeli głównej z 1 kryterium - widzowie #25

Żeby stworzyć tabelę pomocniczą, która wypełnia się sama na podstawie tabeli głównej i 1 kryterium trzeba zbudować taką formułę.

=JEŻELI.BŁĄD(INDEKS(Tabela13[#Dane];MIN.K(JEŻELI(Fabryka=$G$2;WIERSZ(Fabryka)-WIERSZ($A$5)+1);ILE.WIERSZY($F$5:$F5));LICZBA.KOLUMN($A$5:A$5));"")

Rdzeniem tej formuły jest funkcja INDEKS której podajemy parametry, które pozwolą mam odnaleźć odpowiednią komórkę w tabeli głównej.

Pierwszy argument (Tabela13[#Dane]) to tabela główna.
Trzeci argument (LICZBA.KOLUMN($A$5:A$5)) prosto mówi, z której kolumny pobierać dane przez prosty rozrost obszaru kolumn przy przeciąganiu formuł w prawo w tabeli pomocniczej.

Drugi parametr (MIN.K(JEŻELI(Fabryka=$G$2;WIERSZ(Fabryka)-WIERSZ($A$5)+1);ILE.WIERSZY($F$5:$F5))) jest najbardziej skomplikowany.

Przede wszystkim sprawdzamy w nim kryterium (Fabryka=$G$2) a następnie za pomocą funkcji JEŻELI tworzymy z tego sprawdzenia tablicę relatywnych pozycji wierszy, gdzie kryterium jest spełnione i wartości FAŁSZ w wierszach, gdzie nie jest spełnione.

Następnie z tej tablicy wybieramy po kolei wiersze od najmniejszych do coraz większych wraz z przesuwaniem się w dół w tabeli pomocniczej. Zapewnia nam to funkcja MIN.K i odwołanie do liczenia ile wierszy w dół już zeszliśmy w tabeli pomocniczej ILE.WIERSZY($F$5:$F5) ważne tu jest całkowite zalokowanie pierwszego fragmentu zakresu a drugiego pozostawionego swobodnego przy kopiowaniu w dół, że ta wartość rosła co 1 z każdym kolejnym wierszem.

Ponieważ łatwo trafimy na sytuację, gdzie liczba wierszy w kolumnie pomocniczej będzie większa niż liczba wierszy spełniająca warunek kryterium dlatego potrzebujemy jeszcze sobie poradzić z błędem za pomocą funkcji JEŻELI.BŁĄD i wstawienia pustego ciągu znaków w takiej sytuacji ""

Na koniec trzeba pamiętać o zatwierdzeniu formuły kombinacją klawiszy Ctrl + Shift + Enter bo zawiera obliczenia tablicowe i skopiowaniu jej na wszystkie komórki tabeli pomocniczej.

P.S.

Jeśli chcesz dowiedzieć się więcej na temat Excela lub nie wiesz jak coś zrobić do mnie o tym w komentarzu pod spodem albo napisz do mnie bezpośrednio, ja w miarę możliwości odpowiem na Twoje pytanie.

Excel i Adam - kontakt

Bezpośredni odnośnik do filmu na youtube — Automatyczne wypełniana tabela pomocniczej z tabeli głównej z 1 kryterium — widzowie #25