Jak stworzyć obraz, który zmienia się w zależności od pozycji na liście rozwijanej?


Obraz na podstawie listy rozwijanej — porada #126

Obraz na podstawie listy rozwijanej - porada #126

Żeby stworzyć obraz, który zmienia się w zależności od pozycji na liście rozwijanej. Przede wszystkim trzeba mieć przygotowaną odpowiednią tabelę, gdzie w 1 kolumnie są nazwy przypisane do obrazów, a w 2 są obrazy.

Ważne, żeby każdy obraz znajdował się w osobnej komórce i nie wychodził poza jej krawędzie.

Następnie wystarczy prosta formuła wyszukująca, wykorzystująca funkcję INDEKS i PODAJ.POZYCJĘ.
W indeksie zaznaczamy tablicę, czyli zakres komórek, gdzie znajdują się obrazki, a za pomocą PODAJ.POZYCJĘ wyszukujemy pozycji elementu z listy rozwijanej w naszej tabeli pomocniczej.

=INDEKS($H$2:$H$4;PODAJ.POZYCJĘ($B$2;$G$2:$G$4;0))

Tak stworzonej formule musimy przypisać nazwę w menadżerze nazw (Ctrl + F3).
Następnie tą nazwę przypisujemy do obrazu: klikamy w niego i naciskamy F2, by w pasku formuły wpisać odpowiednią nazwę.

Ważne jest, że przypisać tak formułę można tylko do 1 komórki z listą rozwijaną. Czyli jeśli chcesz mieć 2 obraz, który reaguje na zmiany innej listy musisz stworzyć nową formułę i nadać jej inną nazwę, nawet jeśli różni się ona tylko pojedynczym argumentem.

P.S.

Jeśli chcesz dowiedzieć się więcej na temat Excela lub nie wiesz jak coś zrobić to napisz do mnie. Ja w miarę możliwości odpowiem na Twoje pytanie.

Excel i Adam - kontakt

Bezpośredni odnośnik do filmu na youtube — Obraz na podstawie listy rozwijanej — porada #126