Załóżmy, że masz kalendarz i chcesz w nim zaznaczyć dni na które przypada urlop. Kolejne urlopy mamy zapisane jako daty od do.

widzowie 116 - Jak zaznaczyć urlop w kalendarzu 01

Żeby to zrobić musimy najpierw napisać formułę, która będzie sprawdzać, czy dana data jest jednocześnie większa bądź równa dacie od i mniejsza bądź równa dacie do. Tylko nie będziemy tego robić na pojedynczych datach tylko od razu na kolumnie dat od i kolumnie dat do. Standardowo przy formatowaniu warunkowym najpierw piszemy formułę w komórkach obok, a jak ją przetestujemy to przeklejamy do formatowania warunkowego.

Czyli zaczynamy od porównania pojedynczej daty (komórka C3) z kolumną dat od:

=C3>=$AT$2:$AT$14

widzowie 116 - Jak zaznaczyć urlop w kalendarzu 02

Powyższa operacja porównania zwróci nam tablicę wartości PRAWDA i FAŁSZ. Tą operację porównania musimy połączyć jeszcze ze sprawdzeniem czy pojedyncza data (C3) jest mniejsza bądź równa od dat do (końca urlopu). Najszybciej połączymy te operacje porównania za pomocą mnożenia. Musimy tylko pamiętać o kolejności operacji dlatego operacje porównania musimy wstawić w nawiasach.

=(C3>=$AT$2:$AT$14)*(C3=$AU$2:$AU$14)

widzowie 116 - Jak zaznaczyć urlop w kalendarzu 03

Tym razem gdybyśmy podejrzeli wynik naszej formuły to otrzymalibyśmy tablicę 0 i 1, najczęściej tylko zer. Jedynka pojawiłaby się tylko wtedy, kiedy przypadałby urlop na podstawie konkretnej pary od do.

={0;0;0;0;0;0;0;0;0;0;0;0;0}

Teraz potrzebujemy zsumować wynikową tablicę. Najlepiej to zrobić funkcją SUMA.ILOCZYNÓW – dzięki temu nie będziemy się musieli martwić, że pracujemy z formułami tablicowymi.

=SUMA.ILOCZYNÓW((C3>=$AT$2:$AT$14)*(C3=$AU$2:$AU$14))

Po przeciągnięciu formuły w bok i dół uzyskamy 1 tam gdzie przypada urlop.

widzowie 116 - Jak zaznaczyć urlop w kalendarzu 04

Teraz wystarczy skopiować formułę do formatowania warunkowego po zakresie dat naszego kalendarza i już będę one podświetlały się ponieważ formatowanie warunkowe 0 potraktują jako wartości FAŁSZ, a 1 jako wartości PRAWDA.

widzowie 116 - Jak zaznaczyć urlop w kalendarzu 05

P.S. Jeśli nie chcesz, żeby w tym mini kalendarzu urlopy zaznaczały się podwójnie, czyli na datach, które nie przypadają na konkretny miesiąc w wierszu musisz dopisać jeszcze jeden warunek do formuły:

=SUMA.ILOCZYNÓW((C3>=$AT$2:$AT$14)*(C3=$AU$2:$AU$14)*(MIESIĄC($B3)=MIESIĄC(C3)))

widzowie 116 - Jak zaznaczyć urlop w kalendarzu 06

Mini kalendarz w arkuszu — porada #167
https://www.youtube.com/watch?v=xfsTU4IVP_k

Pozdrawiam
Adam Kopeć
Miłośnik Excela
Microsoft MVP