Jak policzyć przepracowaną liczbę dni w weekendach?

Jak zliczyć pracujące dni weekendu — widzowie #47 Jak zliczyć pracujące dni weekendu - widzowie #47

Żeby policzyć ile dni weekendowych jest pracujących, przy założeniu, że mamy daty poszczególnych dni i dni pracujące rozróżniamy po liczbie przepracowanych godzin, możemy wykorzystać proste sprawdzenie jaki to dzień tygodnia za pomocą formuły:

=DZIEŃ.TYG($A$2:$A$31;2)>5

oraz czy w danej komórce wstawiono wartość liczbową

=CZY.LICZBA($B$2:$B$31)

Możemy te warunki połączyć w funkcji SUMA.ILOCZYNÓW tylko potrzebujemy zamienić wartości PRAWDA i FAŁSZ zamienić na jedynki i zero, ponieważ funkcja SUMA.ILOCZYNÓW nie radzi sobie z wartościami logicznymi.
Najprościej to zrobić za pomocą podwójnego minusa.

=SUMA.ILOCZYNÓW(–(DZIEŃ.TYG($A$2:$A$31;2)>5);–CZY.LICZBA($B$2:$B$31))

Tej formuły nie musisz zatwierdzać jako formuły tablicowej (Ctrl + Shift + Enter) ponieważ funkcja SUMA.ILOCZYNÓW radzi sobie z operacjami tablicowymi.

Jeśli nie miałbyś dat przy dniach możesz skorzystać z formuły sprawdzającej tylko dni z weekendów, ale jest bardziej uciążliwe, bo musisz zaznaczać poszczególne weekendy osobno:

=SUMA(–CZY.LICZBA(B3:B4);–CZY.LICZBA(B10:B11))

tą formułę musisz zatwierdzić jako formułę tablicową (Ctrl + Shift + Enter)

P.S.

Jeśli chcesz dowiedzieć się więcej na temat Excela lub nie wiesz jak coś zrobić to napisz do mnie. Ja w miarę możliwości odpowiem na Twoje pytanie.

Excel i Adam - kontakt

Bezpośredni odnośnik do filmu na youtube — Jak zliczyć pracujące dni weekendu — widzowie #47