Jak dodać metry kwadratowe poprawnie w Excelu?


Dodawanie metrów kwadratowych — 2 sposoby — widzowie #15

Dodawanie metrów kwadratowych - 2 sposoby - widzowie #15

Jak dodać metry kwadratowe (m2) w Excelu? W tym wideo znajdziesz 2 rozwiązanie.

Pierwsze przy założeniu w sytuacji gdy metry kwadratowe są zapisane jako tekst 12,3 m² i trzeba się bardzie napocić, żeby wyciągnąć wartości liczbowe. Należy najpierw wyciągnąć funkcją LEWY wartość liczbową mniejszą o 2 ostatnie znaki (przyda się funkcja DŁ można to zrobić w osobnej kolumnie i formuły będę wyglądać tak:

=LEWY(B1;DŁ(B1)-2)+0

Na końcu formuły dodajesz zero, ponieważ funkcja LEWY zwraca tekst, którego nie da się sumować, a dodanie zera zapewnia konwersję na liczbę.

Po tym wystarczy funkcja SUMA do zsumowania wyniku.

Żeby zrobić te obliczenia w 1 komórce trzeba wykorzystać formuły tablicowe:

{=SUMA(LEWY(B1:B2;DŁ(B1:B2)-2)+0)&" m2"}

trzeba zatwierdzić kombinacją klawiszy Ctrl + Shift + Enter. Można to obejść korzystając z funkcji SUMA.ILOCZYNÓW, która radzi sobie z formułami tablicowymi, bez zatwierdzania specjalnym ciągiem klawiszy

=SUMA.ILOCZYNÓW(LEWY(B1:B2;DŁ(B1:B2)-2)+0)&" m2"

Drugie rozwiązanie wykorzystuje formatowanie niestandardowe np:

0,00"m2"

dzięki temu obok wartości liczbowych pojawi się symbol metrów kwadratowych (m2), ale nie będzie ich rzeczywiście w komórce i Excel będzie te komórki traktował jako liczba i będzie je można zsumować funkcją SUMA.

=SUMA(F1:F2)

P.S.

Jeśli chcesz dowiedzieć się więcej na temat Excela lub nie wiesz jak coś zrobić do mnie o tym w komentarzu pod spodem albo napisz do mnie bezpośrednio, ja w miarę możliwości odpowiem na Twoje pytanie.

Excel i Adam - kontakt

Bezpośredni odnośnik do filmu na youtube — Dodawanie metrów kwadratowych — 2 sposoby — widzowie #15