Jak wyszukiwać kolumna po kolumnie?


Wyszukiwanie kolumna po kolumnie — porada #156

Wyszukiwanie kolumna po kolumnie - porada #156

Żeby wyszukiwać dane w Excelu najczęściej korzysta się z funkcji WYSZUKAJ.PIONOWO. Standardowy zapis to np:

=WYSZUKAJ.PIONOWO($A$2;$A$5:$E$11;2;0)

Jest z nim problem jeśli szukamy kilku kolumn znajdujących się obok siebie, bo jeśli przeciągniemy ją w prawo, to ciągle będzie wyszukiwać 2 kolumną z tabeli danych, a my chcielibyśmy wyszukiwać 3, 4, itd… Oczywiście można pozmieniać numer kolumn w skopiowanych formułach, ale mój czytelnik Michał zaproponował inne rozwiązanie napisania formuły:

=WYSZUKAJ.PIONOWO(A2;A5:$E$11;2;0)

Ta formuła zadziała, gdy szukamy kolumna po kolumnie, ponieważ przesuwając się w prawo, szuka elementu już wyszukanego, na obszarze zmniejszonym o pierwszą kolumnę.

P.S.

Jeśli chcesz dowiedzieć się więcej na temat Excela lub nie wiesz jak coś zrobić to napisz do mnie. Ja w miarę możliwości odpowiem na Twoje pytanie.

Excel i Adam - kontakt

Bezpośredni odnośnik do filmu na youtube — Wyszukiwanie kolumna po kolumnie — porada #156