Jak znaleźć k‑ty duplikat przy posortowanej liście?

Jeśli masz posortowaną listę i szukasz k‑tego wystąpienia danego wyrazu (duplikatu) to jest to bardzo proste.


Wyszukiwanie k‑tego duplikatu gdy kolumna jest posortowana — sztuczki #27

Zacznijmy od tego, że potrzebujesz mieć 2 warunki wyraz którego szukasz (w tym przykładzie będzie to imię) oraz numer wystąpienia, którego szukasz.

Dane wejściowe i warunki zaznaczone na czerwono

Dane wejściowe i warunki zaznaczone na czerwono

Teraz zaczynasz od wyszukania pozycji pierwszego wystąpienia danego wyrazu. Wykorzystujesz do tego funkcję PODAJ.POZYCJĘ z ustawieniem ostatniego argumentu na dopasowanie dokładne (0).

=PODAJ.POZYCJĘ(E2;A2:A13;0)

Ponieważ jednak potrzebujesz pozycji relatywnej konkretnego wystąpienia, potrzebujesz jeszcze dodać numer duplikatu, którego szukasz i odjąć jedynkę by uzyskać prawidłowy wynik (pozycję)

=PODAJ.POZYCJĘ(E2;A2;0)+D2‑1

Zanaleziona pozycja wybranego duplikatu

Zanaleziona pozycja wybranego duplikatu

Kiedy masz już dokładną pozycję możesz wykorzystać funkcję INDEKS by znaleźć konkretną wartość odpowiadającą danemu duplikatowi, szczególnie tą znajdującą się w kolumnie obok:

=INDEKS(B2:B13;PODAJ.POZYCJĘ(E2;A2:A13;0)+D2‑1)

Znaleziona wartość dla zadanych warunków

Znaleziona wartość dla zadanych warunków

P.S.

Wpis na podstawie Excel Magic Trick 1003

Jeśli chcesz dowiedzieć się więcej na temat Excela lub nie wiesz jak coś zrobić do mnie o tym w komentarzu pod spodem albo napisz do mnie bezpośrednio, ja w miarę możliwości odpowiem na Twoje pytanie.

Excel i Adam - kontakt

Bezpośredni odnośnik do filmu na youtube — Wyszukiwanie k‑tego duplikatu gdy kolumna jest posortowana — sztuczki #27