Pojawiający się i znikający wynik


Tajemnicza kolumna — Pytania widzów 1

Pytanie Ali

Ten post jest odpowiedzią na pytanie użytkownika Ala nowa. Ala widziała przykład, w którym były pokazane 3 kolumny. 1 pusta, 2 z liczbami i 3 też z pozoru pusta.

Po wpisaniu do pierwszej kolumny liczby w trzeciej kolumnie pojawiał się wynik mnożenia 1 kolumna * 2 kolumna.

Właśnie 3 kolumna jest sekretem całej operacji. Zobacz co znajduje się w 3 kolumnie. Co w niej się znajduje? To tajemnica :P. OK, ok to tylko niewinny żarcik.

Oczywiście w tajemniczej kolumnie, a właściwie w jej komórkach znajdują odpowiednie formuły, które korzystają z funkcji JEŻELI.

Jeśli znasz działanie funkcji JEŻELI w Excelu i wiesz jak oznaczyć i wpisać do komórki pusty znak (to się robi wpisując dwa znaki cudzysłowu obok siebie — ""). To możesz sprawić, że tajemnicza kolumna będzie pokazywała wynik tylko wtedy kiedy będzie on różny od zera.

Warto wiedzieć, że w Excelu wynik przemnożenia pustej komórki przez dowolną liczbę to właśnie zero.

Funkcja JEŻELI w magicznej kolumnie

Jak ma wyglądać funkcja JEŻELI, żeby uzyskać taki efekt? Przede wszystkim w teście logicznym trzeba sprawdzić czy wynik mnożenia jest równy 0. Teraz są dwie sytuacje, kiedy jest to prawdą i kiedy nie jest to prawdą, czyli pozostaje uzupełnienie 2 pozostałych parametrów funkcji JEŻELI:

  • wartość_jeżeli_prawda, czyli co wpisać jeśli test logiczny daje wynik prawdziwy?
  • wartość_jeżeli_fałsz, czyli co wpisać jeśli test logiczny daje wynik fałszywy?

W naszej sytuacji wystarczy podstawić pod wartość wartość_jeżeli_prawda — dwa cudzysłowy obok siebie — "", a pod wartość_jeżeli_fałsz — wpisać wynik mnożenia, czyli np: B3*C3.

Końcowy wygląd formuły w komórkach tajemniczej kolumny może wyglądać tak:

=JEŻELI(B3*C3=0;"";B3*C3)

To jest jedna z możliwości, bo możesz równie dobrze sprawdzać czy wynik jest różny od zera. Wtedy formuła w komórce powinna wyglądać tak:

=JEŻELI(B3*C3>0;B3*C3;"")

P.S.

Jeśli masz pytanie związane z Excelem, chcesz się czegoś na jego temat dowiedzieć, lub nie wiesz jak coś zrobić napisz o tym w komentarzu pod filmem albo napisz do mnie bezpośrednio, ja w miarę mojego wolnego czasu odpowiem na to pytanie.

Bezpośredni odnośnik do filmu na youtube — Tajemnicza kolumna — Pytania widzów 1