Jak zliczyć wystąpienia 47 w komórkach, którą są i tekstem i liczbami?

Dostałem zapytanie żeby zliczyć komórki, gdzie wystąpiła liczba 47. Dane w komórkach mogą wyglądać tak:


Licz wystąpienia w komórkach, nie ważne czy tekst czy liczba — widzowie #7

Przykładowe dane

Przykładowe dane

Czyli czasami 47 jest sama, czasami na początku tekstu, a czasem w środku. Jak w takim razie to policzyć, skoro funkcja LICZ.JEŻELI nie zadziała.

Postanowiłem wykorzystać funkcję SZUKAJ.TEKST. Początkowo myślałem, że będę musiał zapisać daną jako tekst, czyli "47" (47 w cudzysłowach), ale okazało się to zbędne. Funkcja SZUKAJ.TEKST odnajdywała 47 nie ważne jak była traktowana przez Excel. Czy komórka była wyrównana do prawej i oznaczała liczbę, czy do lewej i oznaczała tekst.

Teraz miałem liczby, gdy SZUKAJ.TEKST znalazło 47 i błąd #ARG! gdy nie znalazło

{1;1;#ARG!;5}

Potrzebowałem wiedzieć tylko czy liczba występuje, dlatego wykorzystałem funkcję CZY.LICZBA. Teraz miałem wartości PRAWDA i FAŁSZ :

{PRAWDA;PRAWDA;FAŁSZ;PRAWDA}

Niestety tych wartości nie da się łatwo zsumować. Trzeba je zamienić na 1 i 0 przez prostą operację matematyczną np: 2 minusy przed funkcją CZY.LICZBA.

Jak uzyskałem 1 i 0 wystarczyło je zsumować, czyli końcowa formuła wygląda tak:

=SUMA(–CZY.LICZBA(SZUKAJ.TEKST(D5;B1:B4)))

Pamiętaj ją zatwierdzić Ctrl + Shift + Enter , bo to formuła tablicowa.

Wynik działania formuły

Wynik działania formuły

P.S.

Jeśli chcesz dowiedzieć się więcej na temat Excela lub nie wiesz jak coś zrobić do mnie o tym w komentarzu pod spodem albo napisz do mnie bezpośrednio, ja w miarę możliwości odpowiem na Twoje pytanie.

Excel i Adam - kontakt

Bezpośredni odnośnik do filmu na youtube — Licz wystąpienia w komórkach, nie ważne czy tekst czy liczba — widzowie #7