Mówi się, że przeciętny użytkownik Excela zna około 2% jego możliwości. Dla nas nie jest istotne ile tych procent faktycznie jest, ale żeby nauczyć się korzystać z tego co umiesz, bo w Excelu, jak w życiu, jest wiele sposobów na rozwiązanie problemów, które stoją przed Tobą. Dlatego w tym wpisie chodzi przede wszystkim o to, żeby nakłonić Cię do myślenia, żebyś wykorzystał swoje szare komórki i umiejętności do rozwiązania problemu, a nie żebyś załamywał ręce.

Zrobimy to na przykładzie podziału danych osobowych na pierwsze imię, drugie imię i nazwisko. Robimy założenie, że znamy polecenie Tekst jako kolumny i JEŻELI.

porada-282-wyciaganie-drugiego-imienia-tekst-jako-kolumny-i-jezeli-dzialaj-jak-umiesz-01

W pierwszym kroku wystarczy, że dane osobowe podzielimy za pomocą polecenia Tekst jako kolumny z karty Dane 

porada-282-wyciaganie-drugiego-imienia-tekst-jako-kolumny-i-jezeli-dzialaj-jak-umiesz-02

według ogranicznika,

porada-282-wyciaganie-drugiego-imienia-tekst-jako-kolumny-i-jezeli-dzialaj-jak-umiesz-03

którym będzie spacja

porada-282-wyciaganie-drugiego-imienia-tekst-jako-kolumny-i-jezeli-dzialaj-jak-umiesz-04

na kolumny i wstawimy do komórki B2.

porada-282-wyciaganie-drugiego-imienia-tekst-jako-kolumny-i-jezeli-dzialaj-jak-umiesz-05

Nasz podział nie będzie idealny, bo czasami będziemy mieli 2, a czasami 3 kolumny, ale tutaj z pomocą przyjdzie nam jeszcze funkcja JEŻELI. Najpierw będziemy sprawdzać czy jest drugie imię – jeśli jest wypełniona 3 kolumna to znaczy, że jest drugie imię, co się przekłada na formułę:

=JEŻELI(D3="";"";C3)

porada-282-wyciaganie-drugiego-imienia-tekst-jako-kolumny-i-jezeli-dzialaj-jak-umiesz-06

W podobny sposób, jeśli 3 kolumna nie jest pusta oznacza to, że jest w niej nazwisko, a jeśli jest to znaczy, że nazwisko jest w 2 kolumnie, czyli możemy odpowiednio napisać taką formułę:

=JEŻELI(D2>"";D2;C2)

porada-282-wyciaganie-drugiego-imienia-tekst-jako-kolumny-i-jezeli-dzialaj-jak-umiesz-07

Może nie jest to najelegantszy sposób na rozwiązanie tego problemu, ale w większości sytuacji wystarczający i przede wszystkim opiera się, z założenia, o znane nam funkcjonalności Excela 😉

Pozdrawiam
Adam Kopeć
Miłośnik Excela