Jak wyszukać kolejne wartości dla tego samego kryterium?

Zwracanie kolejnych wartości dla tego samego kryterium — porada #164 Zwracanie kolejnych wartości dla tego samego kryterium - porada #164

Czasami chcesz wyszukać nie tylko wystąpienie wartości jak to robi funkcja WYSZUKAJ.PIONOWO, ale też kolejne. Niestety w Excelu musisz się nad tym napracować.

Potrzebujesz najpierw sprawdzić czy w danym wierszu jest szukana wartość, a następnie jeśli jest to wstawić numer pozycji na liście, a jeśli nie to zostawić FAŁSZ. Możesz to osiągnąć za pomocą kombinacji funkcji JEŻELI i WIERSZ:

=JEŻELI($A$2:$A$11=$D2;WIERSZ($A$2:$A$11)-WIERSZ($A$2)+1)

dzięki temu uzyskamy ciąg w stylu:

{1;FAŁSZ;FAŁSZ;FAŁSZ;FAŁSZ;FAŁSZ;7;8;FAŁSZ;FAŁSZ}

teraz będziemy chcieli wyciągać kolejne minimalne wartości, czyli będziemy potrzebować funkcji MIN.K i NR.KOLUMNY (żeby zmieniać wartość parametru k automatycznie).

=MIN.K(JEŻELI($A$2:$A$11=$D2;WIERSZ($A$2:$A$11)-WIERSZ($A$2)+1);NR.KOLUMNY(A1))

ta formuła będzie zwracała kolejne pozycje wystąpienia danego argumentu, jak będziemy ją kopiować w bok.

Teraz wystarczy jeszcze dołożyć funkcję INDEKS i zakres tablicy, z której chcemy pobierać wartości.

=INDEKS($B$2:$B$11;MIN.K(JEŻELI($A$2:$A$11=$D2;WIERSZ($A$2:$A$11)-WIERSZ($A$2)+1);NR.KOLUMNY(A1)))

Na koniec ewentualnie możemy dołożyć obsługę błędów:

=JEŻELI.BŁĄD(INDEKS($B$2:$B$11;MIN.K(JEŻELI($A$2:$A$11=$D2;WIERSZ($A$2:$A$11)-WIERSZ($A$2)+1);NR.KOLUMNY(A1)));"brak ceny")

Te formuły trzeba zatwierdzić kombinacją klawiszy Ctrl + Shift + Enter ponieważ są to formuły tablicowe.

P.S.

Jeśli chcesz dowiedzieć się więcej na temat Excela lub nie wiesz jak coś zrobić to napisz do mnie. Ja w miarę możliwości odpowiem na Twoje pytanie.

Excel i Adam - kontakt

Bezpośredni odnośnik do filmu na youtube — Zwracanie kolejnych wartości dla tego samego kryterium — porada #164