Jak przypisać numery liczby porządkowej według wartości sprzedaży?


Liczba porządkowa według wartości sprzedaży — pomijane wartości zerowe — widzowie #38

Liczba porządkowa według wartości sprzedaży - pomijane wartości zerowe - widzowie #38

Kiedy chcemy w Excelu porządkować wartości według wyników sprzedaży, a przy okazji nie brać pod uwagę pustych wierszy lub wierszy z wartością zerową przyda nam się kolumna pomocnicza sprawdzająca, czy komórka sprzedaży jest pusta lub ma wartość zerową. W większości sytuacji pusta komórka jest tożsama zeru, ale nie w sytuacji, gdy przechowuje pusty ciąg znaków ""

W naszej sytuacji możemy sprawdzić te 2 warunki prostą formułą:

=D2 <> 0

Teraz wystarczy dołożyć ten warunek do wcześniejszej formuły z filmu Excel — Liczba porządkowa według wartości sprzedaży — widzowie #37

=LICZ.WARUNKI($C$2:$C$14; c3;$d$2: $D$14;">"&D3;$E$2:$E$14;PRAWDA)+1

Pojawia się jeszcze problem, że przy pustych i zerowych wartościach sprzedaży pojawiają się numery liczby porządkowej. Łatwo sobie z tym poradzić otaczając naszą formułę funkcją  JEŻELI

=JEŻELI(D2=0;"zero";LICZ.WARUNKI($C$2:$C$14;C2;$D$2:$D$14;">"&D2;$E$2:$E$14;PRAWDA)+1)

P.S.

Jeśli chcesz dowiedzieć się więcej na temat Excela lub nie wiesz jak coś zrobić to napisz do mnie. Ja w miarę możliwości odpowiem na Twoje pytanie.

Excel i Adam - kontakt

Bezpośredni odnośnik do filmu na youtube — Liczba porządkowa według wartości sprzedaży — pomijane wartości zerowe — widzowie #38