Jak sumować, gdy symbolom przypisane są wartości liczbowe?


Suma po symbolach gdy symbolowi przypisana jest liczba — widzowie #43

Suma po symbolach gdy symbolowi przypisana jest liczba - widzowie #43

Dostałem zapytanie jak sumować symbole, którym przypisane są liczby.
Czyli mamy kolumnę, gdzie są puste komórki i symbole i potrzebujemy zliczyć sumaryczną wartość wszystkich symboli.

1 rozwiązanie wykorzystuje kolumnę pomocniczą i funkcję WYSZUKAJ.PIONOWO Potrzebujemy tylko jeszcze poradzić sobie z pustymi komórkami, które zwracają błędy przy wyszukiwaniu. Najprościej wykorzystać funkcję JEŻELI, która zwróci zero kiedy komórka jest pusta, a zacznie wyszukiwać, gdy komórka nie jest pusta.

=JEŻELI(B1="";0;WYSZUKAJ.PIONOWO(B1;$E$2:$F$6;2;0))

teraz na końcu kolumny wystarczy wstawić funkcję SUMA.

2 rozwiązanie ma na celu zrobienie tego w jednej komórce. Niestety funkcja WYSZUKAJ.PIONOWO nie przyjmuje zakresu do wyszukania, dlatego musimy skorzystać z innej funkcji. Przydaje się nam funkcja WYSZUKAJ Podobnie jak poprzednio trzeba ją wstawić w funkcję JEŻELI żeby obsłużyć puste komórki i jeszcze w funkcję SUMA , żeby wszystko podliczyć.

=SUMA(JEŻELI(B1:B12="";0;WYSZUKAJ(B1:B12;E2:E6;F2:F6)))

Tą formułę trzeba zatwierdzić kombinacją klawiszy Ctrl + Shift + Enter bo jest to formuła tablicowa.

Przy funkcji WYSZUKAJ ważne jest, że zawsze dokonuje wyszukiwania przybliżonego, czyli potrzebujemy posortować nasze symbole, żeby uzyskać prawidłowy wynik.

P.S.

Jeśli chcesz dowiedzieć się więcej na temat Excela lub nie wiesz jak coś zrobić to napisz do mnie. Ja w miarę możliwości odpowiem na Twoje pytanie.

Excel i Adam - kontakt

Bezpośredni odnośnik do filmu na youtube — Suma po symbolach gdy symbolowi przypisana jest liczba — widzowie #43