Do czego przydaje się ignorowanie tekstu przez funkcję SUMA?

SUMA ignoruje tekst Suma bieżąca — porada #175 SUMA ignoruje tekst   Suma bieżąca - porada #175

Funkcja SUMA i jej podobne (ŚREDNIA, SUMA.JEŻELI itp.) ignoruje przy obliczeniach:

  • wartości tekstowe,
  • liczby, które zostały zapisane jako tekst,
  • wartości logiczne (PRAWDA i FAŁSZ).

To daje nam możliwości zrobienia różnych rzeczy np: Sumy bieżącej za pomocą jednej formuły w kolumnie. Zaczynamy od sumowania nowej wartości i nagłówka, a dalej wystarczy skopiować w dół.

=SUMA(B2;C1)

Podobnie możesz obliczyć różnice pomiędzy kolejnymi wartościami, tylko musisz pozamieniać znaki minus, bo tekstu z nagłówka nie możesz zamienić na liczbę przeciwną.

=-SUMA(-P2;P1)

To rozwiązanie wykorzystałem w analizie ABC:

P.S.

Jeśli chcesz dowiedzieć się więcej na temat Excela lub nie wiesz jak coś zrobić to napisz do mnie. Ja w miarę możliwości odpowiem na Twoje pytanie.

Excel i Adam - kontakt

Bezpośredni odnośnik do filmu na youtube — SUMA ignoruje tekst Suma bieżąca — porada #175