Jak stworzyć posortowaną i dynamiczną tabelę z wynikami sesji strzeleckich?


Max wyniki strzelania dynamicznie w tabeli malejąco — widzowie #28

Max wyniki strzelania dynamicznie w tabeli malejąco - widzowie #28

Jak z tabeli wyników strzelania zawodników stworzyć tabelę, która będzie uporządkowywała wyniki od maksymalnego do minimalnego i żeby była dynamiczna.

Potrzebujemy funkcji:

=JEŻELI(ILE.WIERSZY($L$2:L2)>ILE.NIEPUSTYCH(Tabela14[Max]);"";MAX.K(Tabela14[Max];ILE.WIERSZY($L$2:L2)))

Do pokazania w kolejności wyników od max do min i obsłużeniem błędu, gdy wybierzemy więcej elementów niż jest na liście.

Formuła pod spodem posłuży by wypisać w odpowiedniej kolejności osoby, które osiągnęły wyniki od max do min:

=JEŻELI(ILE.WIERSZY($L$2:L2)>ILE.NIEPUSTYCH(Tabela14[Max]);"";INDEKS(Tabela14[[Nazwisko]:[Imię]];MIN.K(JEŻELI(Tabela14[Max]=[@[Max.k]];WIERSZ(Tabela14[Max])-WIERSZ($C$2)+1);LICZ.WARUNKI($L$2:$L2;$L2));LICZBA.KOLUMN($M$2:M2)))

Powyższa formuła jest formułą tablicową i trzeba ją zatwierdzić kombinacją klawiszy Ctrl + Shift + Enter.

Użyte funkcje:
MAX
MAX.K
ILE.WIERSZY
ILE.NIEPUSTYCH
INDEKS
LICZ.WARUNKI
WIERSZ
LICZBA.KOLUMN
MIN.K
JEŻELI
JEŻELI.BŁĄD

P.S.

Jeśli chcesz dowiedzieć się więcej na temat Excela lub nie wiesz jak coś zrobić do mnie o tym w komentarzu pod spodem albo napisz do mnie bezpośrednio, ja w miarę możliwości odpowiem na Twoje pytanie.

Excel i Adam - kontakt

Bezpośredni odnośnik do filmu na youtube — Max wyniki strzelania dynamicznie w tabeli malejąco — widzowie #28