Jak policzyć liczbę słów w zakresie komórek?

Jak policzyć liczbę słów — porada #165 Jak policzyć liczbę słów - porada #165

Żeby policzyć liczbę słów wystarczy policzyć liczbę spacji i dodać jeden. Czyli przekłada się to na formułę e Excelu:

=DŁ(C3)-DŁ(PODSTAW(C3;" ";""))+1

Funkcja PODSTAW zamienia spacje na pusty ciąg znaków i dzięki temu z długości możemy wywnioskować ile było spacji.

To najbardziej podstawowe obliczenie, ale możemy poszerzyć obszar liczenia słów na zakres komórek. Dołożymy jeszcze do tego zabezpieczenie w postaci funkcji USUŃ.ZBĘDNE.ODSTĘPY, żeby usunąć zbędne spacje.

=DŁ(USUŃ.ZBĘDNE.ODSTĘPY(A1:C5))-DŁ(PODSTAW(A1:C5;" ";""))+1

Ta formuła zwraca ciąg w stylu:

{4\1\1;1\1\1;1\1\3;1\1\1;1\2\1}

Problem się tu pojawia z pustymi komórkami ponieważ zawsze dodajemy jedynkę, więc puste komórki podają, że mają 1 słowo. Żeby to naprawić potrzebujemy sprawdzić, które komórki są puste. Można to zrobić prostą formułą:

=USUŃ.ZBĘDNE.ODSTĘPY(A1:C5)<>""

teraz trzeba połączyć te dwa obliczenia np: w funkcji SUMA.ILOCZYNÓW, trzeba tylko pamiętać, by wyniki PRAWDA i FAŁSZ z drugiej formuły zamienić na 1 i 0 za pomocą podwójnego znaku minus.

=SUMA.ILOCZYNÓW(DŁ(USUŃ.ZBĘDNE.ODSTĘPY(A1:C5))-DŁ(PODSTAW(A1:C5;" ";""))+1;–(USUŃ.ZBĘDNE.ODSTĘPY(A1:C5)<>""))

P.S.

Jeśli chcesz dowiedzieć się więcej na temat Excela lub nie wiesz jak coś zrobić to napisz do mnie. Ja w miarę możliwości odpowiem na Twoje pytanie.

Excel i Adam - kontakt

Bezpośredni odnośnik do filmu na youtube — Jak policzyć liczbę słów — porada #165