Jak wybrać koszt usługi w zależności od parametrów usługi?

Koszt usługi w zależności od przedziałów liczbowych — widzowie #49 Koszt usługi w zależności od przedziałów liczbowych - widzowie #49

Koszt usługi może zmieniać się w zależności od parametrów zamówienia, np: wielkości produktu, użytych kolorów oraz wzorów itp. Przeważnie w zależności w jakim przedziale liczbowym wielkości znajdzie się dany parametr przypada mu odpowiednia cena.

Niestety dla Excela nie można prosto zapisać tych grup 1–4; 5–9 itp ponieważ ciężko będzie mu to zrozumieć. Jako nagłówki w kolejności musisz wpisać dolne granice przedziałów.

Wtedy będziesz mógł skorzystać z funkcji PODAJ.POZYCJĘ do wyszukania odpowiedniego numeru wiersza lub kolumn,

PODAJ.POZYCJĘ(B8;A4:A6;1)

Ważny jest tu ostatni parametr funkcji i to, że w nagłówkach są dolne granice w kolejności rosnącej.

Później z połączeniem z funkcją INDEKS możesz znaleźć odpowiednią cenę.

=INDEKS($B$4:$F$6;PODAJ.POZYCJĘ(B8;A4:A6;1);PODAJ.POZYCJĘ(B9;B3:F3;1))

P.S.

Jeśli chcesz dowiedzieć się więcej na temat Excela lub nie wiesz jak coś zrobić to napisz do mnie. Ja w miarę możliwości odpowiem na Twoje pytanie.

Excel i Adam - kontakt

Bezpośredni odnośnik do filmu na youtube — Koszt usługi w zależności od przedziałów liczbowych — widzowie #49