Jak sumować wybrane 5 komórek w kolumnie w zależności od wiersza w którym jesteś?

Miałem potrzebę, żeby sumować 5 wybranych komórek w zależności od wiersza w którym byłem. Numery wierszy odpowiadały konkretnym datą i w zależności od przedziału, była potrzeba sumować inne zakresy, w grupach po 5 komórek.

Komórki do sumowania i oczekiwany wynik

Komórki do sumowania i oczekiwany wynik


Jak sumować wybrane 5 komórek w kolumnie w zależności od wiersza w którym jesteś — porada #74

Zacząłem od tego, że potrzebowałem wiedzieć, w którym z kolei wierszu jestem i która z kolei to piątka. Zacząłem od funkcji ILE.WIERSZY z wpisanym dynamicznie zakresem:

ILE.WIERSZY($B$2:B2)

Liczenie numeru wiersza przy pomocy dynamicznie powiększającego się zakresu

Liczenie numeru wiersza przy pomocy dynamicznie powiększającego się zakresu

Następnie potrzebowałem wyznaczyć do której z kolei grupy należą poszczególne wiersze. Wykorzystałem funkcję ZAOKR.W.DÓŁ i dzielenie przez 5. Trzeba tylko było zwrócić uwagę, że ILE.WIERSZY zaczyna liczyć od 1, a do uzyskanie prawidłowego podziału na grupy trzeba zacząć od zera, czyli potrzebuje odjąć 1 i zwrócić uwagę na kolejność działań arytmetycznych (dodać nawiasy)

ZAOKR.W.DÓŁ((ILE.WIERSZY($B$2:B2)-1)/5

Podział komórek na grupy w zależności od ich pozycji

Podział komórek na grupy w zależności od ich pozycji

Kiedy mam już podział na grupy mogę użyć funkcji PRZESUNIĘCIE, by znaleźć zakres, który chce zsumować. Zaczynam od 1 komórki zakresu ($C$2), a następnie przesuwam się w dół o ilość wierszy odpowiednią od numeru grupy przemnożonej przez 5, o 0 kolumn, a następnie ma pobrać zakres o wysokości 5 wierszy i 1 kolumnie.

=SUMA(PRZESUNIĘCIE($C$2;5*ZAOKR.W.DÓŁ((ILE.WIERSZY($B$2:B2)-1)/5;1);0;5;1))

Przy funkcji PRZESUNIĘCIE zwróć uwagę na to, że zwraca ono nazwę zakresu, a nie konkretną wartość, więc jeśli będziesz podglądał wynik w trybie edycji klawiszem F9, to uzyskasz inny wynik niż w przy Szacowaniu Formuły.

Funkcja przesunięcie sama zwraca tylko wartość z 1 komórki obszaru

Funkcja przesunięcie sama zwraca tylko wartość z 1 komórki obszaru

Możesz zobaczyć w opisie funkcji przesunięcie albo Szacując formułę, że zwraca ona nazwę zakresu:

Przy szacowaniu formuły widać, że funkcja PRZESUNIĘCIE zwraca zakres

Przy szacowaniu formuły widać, że funkcja PRZESUNIĘCIE zwraca zakres

Zamiast funkcji ILE.WIERSZY możesz użyć funkcji WIERSZ, wtedy formuła będzie wyglądać tak:

=SUMA(PRZESUNIĘCIE($C$2;5*ZAOKR.W.DÓŁ((WIERSZ()-WIERSZ($B$2))/5;1);0;5;1))

Końcowa funkcja sumująca 5 wybranych komórek w zależności od pozycji

Końcowa funkcja sumująca 5 wybranych komórek w zależności od pozycji

P.S.

Jeśli chcesz dowiedzieć się więcej na temat Excela lub nie wiesz jak coś zrobić do mnie o tym w komentarzu pod spodem albo napisz do mnie bezpośrednio, ja w miarę możliwości odpowiem na Twoje pytanie.

Excel i Adam - kontakt

Bezpośredni odnośnik do filmu na youtube — Jak sumować wybrane 5 komórek w kolumnie w zależności od wiersza w którym jesteś — porada #74