Jak znaleźć największą wartość znajdującą się po wybranym fragmencie tekstu?

Jeśli chcesz znaleźć komórkę gdzie po wyszukiwanym fragmencie tekstu jest największa liczba potrzebujesz wykonać kilka kroków. 


Znajdź największą liczbę za fragmentem tekstu — sztuczki #25

Na czerwono szukany tekst, a na zielono wynik końcowego wyszukania

Na czerwono szukany tekst, a na zielono wynik końcowego wyszukania

Najpierw trzeba znaleźć wszystkie wystąpienia szukanego fragmentu tekstu — funkcja SZUKAJ.TEKST, niestety zwraca ona błąd #ARG! jeśli nie znajdzie fragmentu. W naszych obliczeniach będzie to stanowić problem, więc należy dodatkowo wykorzystać funkcję CZY.LICZBA, żeby zamienić wyniki na wartości logiczne PRAWDA (gdy znalazł fragment) i FAŁSZ (gdy nie znalazł)

=CZY.LICZBA(SZUKAJ.TEKST(D2;A2:A10))

W naszym przykładzie mamy zawsze liczbę 2 cyfrową po prawej stronie, więc wyciągamy ją funkcją 

=PRAWY(A2:A10;2)

Wynik działania funkcji PRAWY - znajduje liczby i traktuje je jak tekst

Wynik działania funkcji PRAWY — znajduje liczby i traktuje je jak tekst

Teraz wystarczy zwykłe mnożenie matematyczne, by zamienić wartości logiczne i liczby traktowane jako tekst, na liczby tam gdzie są fragmenty szukanego tekstu i zera gdzie nie ma.

=CZY.LICZBA(SZUKAJ.TEKST(D2;A2:A10))*PRAWY(A2:A10;2)

Wynik działania przemnożenia funkcji PRAWY i SZUKAJ.TEKST

Wynik działania przemnożenia funkcji PRAWY i SZUKAJ.TEKST

Następnie wyciągamy maksymalną liczbę 

=MAX(CZY.LICZBA(SZUKAJ.TEKST(D2;A2:A10))*PRAWY(A2:A10;2))

a później szukamy jej pozycji, czyli funkcja PODAJ.POZYCJĘ wykorzystująca jeszcze raz wcześniejsze obliczenia i pamiętając, że szukamy dokładnego porównania (zero jako ostatni argument):

=PODAJ.POZYCJĘ(MAX(CZY.LICZBA(SZUKAJ.TEKST(D2;A2:A10))*PRAWY(A2:A10;2));SZUKAJ.TEKST(D2;A2:A10)*PRAWY(A2:A10;2);0)

teraz już można wyciągnąć szukaną wartość za pomocą formuły

=INDEKS(B2:B10;PODAJ.POZYCJĘ(MAX(CZY.LICZBA(SZUKAJ.TEKST(D2;A2:A10))*PRAWY(A2:A10;2));SZUKAJ.TEKST(D2;A2:A10)*PRAWY(A2:A10;2);0))

Pamiętaj, żeby zatwierdzić ją Ctrl + Shift + Enter

P.S.

Wpis na podstawie Excel Magic Trick 1001

Jeśli chcesz dowiedzieć się więcej na temat Excela lub nie wiesz jak coś zrobić do mnie o tym w komentarzu pod spodem albo napisz do mnie bezpośrednio, ja w miarę możliwości odpowiem na Twoje pytanie.

Excel i Adam - kontakt

Bezpośredni odnośnik do filmu na youtube — Znajdź największą liczbę za fragmentem tekstu — sztuczki #25