Jak dokonać sumy sprzedaży w określonym zakresie dat w Excelu?


Sumowanie sprzedaży w wybranym zakresie dat — porada #92

Sumowanie sprzedaży w wybranym zakresie dat - porada #92

Zakładamy, że chcemy z sumować wszystkie wartości sprzedaży, które miały miejsce w określonym przedziale czasowym, czyli od daty początkowej do daty końcowej. Wynika z tego, że potrzebujemy 2 warunków i sumowania, czyli wykorzystamy funkcję SUMA.WARUNKÓW.

Na początek sprawdzimy sobie jaka jest najstarsza data (minimalna) w naszym zakresie i najmłodsza (maksymalna), dzięki odpowiednio funkcji MIN i MAX po całym zakresie dat.

Dzięki temu mamy datę od której chcemy sumować. Dokładnie chcemy sumować po kolejnych miesiącach, więc potrzebujemy stworzyć tabelę początków i końców naszych miesięcy. 

Zaczynamy od daty wyznaczonej przez funkcję MIN i na jej podstawie wyznaczamy ostatni dzień miesiąca dzięki funkcji:

=NR.SER.OST.DN.MIES(G5;0)

parametr zero informuje nas, że chcemy mieć ostatni dzień z tego miesiąca. Gdybyśmy wstawili np: ‑1 (minus jeden) to uzyskalibyśmy ostatni dzień poprzedniego miesiąca. Jeśli wstawimy tam 1 (jedynkę) to otrzymamy ostatni dzień z następnego miesiąca.

Kolejnym krokiem jest stworzenie 1 dnia kolejnego miesiąca. Najprościej zrobić to dodają 1 do ostatniego dnia pierwszego miesiąca.

Analogicznie wypełniamy dane do końca dat w naszym zakresie. Końcową datę możemy zostawić taką jaka wynika z naszych obliczeń albo przypisać wartości z funkcji MAX.

Teraz możemy już wstawiać funkcję SUMA.WARUNKÓW z odpowiednimi warunkami mniejsze i równe oraz większe i równe w nawiązaniu do dat.

=SUMA.WARUNKÓW($E$2:$E$325;$A$2:$A$325;">="&G5;$A$2:$A$325;"="&H5)

Uzyskaliśmy sumę sprzedaży w zakresie 2 dat.
Nasze daty możemy dowolnie modyfikować jeśliby zaszła taka potrzeba.

P.S.

Jeśli chcesz dowiedzieć się więcej na temat Excela lub nie wiesz jak coś zrobić napisz do mnie o tym w komentarzu pod spodem albo bezpośrednio. W miarę możliwości odpowiem na Twoje pytanie.

Excel i Adam - kontakt

Bezpośredni odnośnik do filmu na youtube — Sumowanie sprzedaży w wybranym zakresie dat — porada #92