Zakładamy, że mamy przykładowe liczby (wyniki gry losowej) i chcemy je wstawić uporządkowane w kolumny im przypisane. Jest to całkiem proste bo nagłówki kolumn to dokładnie te same numery, które mogą się trafić w losowaniu.
widzowie-103-jak-przypisac-liczby-do-odpowiednich-kolumn-losowanie-lotto-01
W pierwszej kolejności musimy sprawdzić czy dana liczba z nagłówka znajduje się na liście wylosowanych liczb – wystarczy, że skorzystamy z funkcji PODAJ.POZYCJĘ. Jeśli liczba z danego nagłówka kolumny znajduje się na liście wylosowanych liczb, to funkcja PODAJ.POZYCJĘ zwróci tą pozycję (numer pozycji na liście), jeśli jej nie ma, to funkcja PODAJ.POZYCJĘ zwróci błąd (#N/D!).

Na razie nasza formuła (pamiętając o odpowiednich rodzajach odwołań) będzie wyglądać tak:

=PODAJ.POZYCJĘ(B$13;$B3:$AO3;0)

widzowie-103-jak-przypisac-liczby-do-odpowiednich-kolumn-losowanie-lotto-02
Jeśli liczba zostanie odnaleziona, to chcemy zwrócić liczbę z nagłówka, jeśli nie, to chcemy zostawić pustą komórkę. Przyda się nam do tego na pewno funkcja JEŻELI, ale jeszcze będziemy potrzebowali funkcji CZY.LICZBA, która będzie zwracać wartość PRAWDA, gdy liczba zostanie odnaleziona i FAŁSZ, gdy nie zostaje odnaleziona:

=JEŻELI(CZY.LICZBA(PODAJ.POZYCJĘ(B$13;$B3:$AO3;0));B$13;"")

Wystarczy ją przeciągnąć i mamy przyporządkowane liczby do odpowiednich kolumn.

widzowie-103-jak-przypisac-liczby-do-odpowiednich-kolumn-losowanie-lotto-03

Pozdrawiam
Adam Kopeć
Miłośnik Excela