Jak obliczyć ile razy pod rząd wystąpiła wartość?


Ile razy pod rząd pojawia się wartość — porada #155

Ile razy pod rząd pojawia się wartość - porada #155

Jak obliczyć ile razy pod rząd pojawia się dana wartość na liście?
Można jako wykorzystać do tego funkcję CZĘSTOŚĆ i odpowiednio obliczone argumenty.

w parametrze dane będziemy sprawdzać czy znaleźliśmy szukaną wartość

=JEŻELI($A$2:$A$21=$E2;WIERSZ($A$2:$A$21))

jeśli tak to wpisujemy numer wiersza jeśli nie to FAŁSZ (odpowiedni argument JEŻELI pozostaje pusty)

w parametrze przedziały postępujemy bardzo podobnie tylko sprawdzamy, kiedy nie występuje dany argument

=JEŻELI($A$2:$A$21<>$E2;WIERSZ($A$2:$A$21))

Prowadzi to do tego, że funkcja CZĘSTOŚĆ buduje różne przedziały, w których zliczana jest wartość wystąpień pod rząd danej wartości.

=CZĘSTOŚĆ(JEŻELI($A$2:$A$21=$E2;WIERSZ($A$2:$A$21));JEŻELI($A$2:$A$21<>$E2;WIERSZ($A$2:$A$21)))

Teraz wystarczy sprawdzić ile razy powtórzyła się liczba powtórzeń pod rząd, której szukamy, czyli jeśli szukamy powtórzeń wartości 2 razy pod rząd to przyrównujemy wyniku funkcji CZĘSTOŚĆ do dwójki i sumujemy liczbę wystąpień.

=SUMA(–(CZĘSTOŚĆ(JEŻELI($A$2:$A$21=$E2;WIERSZ($A$2:$A$21));JEŻELI($A$2:$A$21<>$E2;WIERSZ($A$2:$A$21)))=F$1))

ponieważ jest to formuła tablicowa potrzebujemy ją zatwierdzić kombinacją klawiszy Ctrl + Shift + Enter

P.S.

Jeśli chcesz dowiedzieć się więcej na temat Excela lub nie wiesz jak coś zrobić to napisz do mnie. Ja w miarę możliwości odpowiem na Twoje pytanie.

Excel i Adam - kontakt

Bezpośredni odnośnik do filmu na youtube — Ile razy pod rząd pojawia się wartość — porada #155