Jak obliczyć ile brakuje Ci sprzedaży do następnego bonusu?

Jeśli masz tabele z zabranymi progami sprzedaży i odpowiadającymi im bonusami, to kwestia wyznaczenia bonusu jaki Ci przysługuje jest bardzo prosty. Wystarczy, że wykorzystasz taką funkcję:

=WYSZUKAJ.PIONOWO(B1;A6:B11;2)


Formuła — Ile brakuje Ci sprzedaży do następnego bonusu — sztuczki #19

Funkcja WYSZUKAJ.PIONOWO wyszykuje przybliżonej wartości (B1) w obszarze (A6:B11), a następnie zwraca wartość bonusu z wyszukanego wiersza i wyznaczonej kolumny (2).

Wyszukany należny bonus dla danej wielkości sprzedaży

Wyszukany należny bonus dla danej wielkości sprzedaży

Jeśli jednak chcesz wyszukać ile brakuje Ci sprzedaży do następnego bonusu potrzebujesz zbudować większą formułę.

Najpierw potrzebujesz znaleźć w tabeli (A6:A11) pozycję gdzie znajduje się próg (B1) dla kolejnego bonusu. Najlepiej wykorzystaj funkcję:

=PODAJ.POZYCJĘ(B1;A6:A11)+1

Do funkcji dodajesz 1 ponieważ zwracany jest wiersz o 1 za nisko.

Znaleziona pozycja kolejnego progu bonusu

Znaleziona pozycja kolejnego progu bonusu

Kiedy masz już pozycję z tabeli, trzeba wyciągnąć wartość z tego pola i odjąć aktualną wartość sprzedaży:

=INDEKS(A6:A11;PODAJ.POZYCJĘ(B1;A6:A11)+1)-B1

Obliczenie ile potrzebujesz by zasłużyć na większy bonus

Obliczenie ile potrzebujesz by zasłużyć na większy bonus

Ewentualnie możesz jeszcze zabezpieczyć się przed błędem, gdy Twoja sprzedaż przekracza próg sprzedaży dla najwyższego bonusu:

=JEŻELI.BŁĄD(INDEKS(A6:A11;PODAJ.POZYCJĘ(B1;A6:A11)+1)-B1;"Masz najwyższy bonus")

P.S.

Wpis na podstawie Excel Magic Trick 995

Jeśli chcesz dowiedzieć się więcej na temat Excela lub nie wiesz jak coś zrobić do mnie o tym w komentarzu pod spodem albo napisz do mnie bezpośrednio, ja w miarę możliwości odpowiem na Twoje pytanie.

Excel i Adam - kontakt

Bezpośredni odnośnik do filmu na youtube — Formuła — Ile brakuje Ci sprzedaży do następnego bonusu — sztuczki #19