Zaznaczanie zakresu tryb rozszerzony — porada #134

Jak włączyć tryb rozszerzony zaznaczenia?


Zaznaczanie zakresu tryb rozszerzony — porada #134

Zaznaczanie zakresu tryb rozszerzony - porada #134

Z książki Witolda Wrotka dowiedziałem się o trybie rozszerzonym zaznaczenie. Wystarczy, że naciśniesz klawisz F8 i teraz możesz używać samych strzałek do zaznaczania zakresu. Zarówno przy wpisywaniu formuł jak i zaznaczaniu obszarów.

Informacja o tym, że Excel jest w trybie rozszerzonym zaznaczenia znajduje się w pasku informacyjnym po lewej stronie.

P.S.

Jeśli chcesz dowiedzieć się więcej na temat Excela lub nie wiesz jak coś zrobić to napisz do mnie. Ja w miarę możliwości odpowiem na Twoje pytanie.

Excel i Adam - kontakt

Bezpośredni odnośnik do filmu na youtube — Zaznaczanie zakresu tryb rozszerzony — porada #134

Łącza do wszystkich arkuszy — porada #133

Jak stworzyć listę linków do arkuszy?


AŁącza do wszystkich arkuszy — porada #133

Łącza do wszystkich arkuszy - porada #133

Żeby stworzyć linki do arkuszy w danym pliku wykorzystamy to co zrobiliśmy we wpisie Lista wszystkich arkuszy — funkcja O.SKOROSZYCIE– porada #130.

Teraz wystarczy funkcja HIPERŁĄCZE by stworzyć linki do arkuszy. Trzeba tylko pamiętać, że jeśli odsyłasz do miejsc w pliku, w którym jest HIPERŁĄCZE to musisz zacząć budować link od płotka — #

czyli przykładowy zbudowany link może wyglądać tak:

#Miki!A1

Po kliknięciu w niego zostaniesz odesłany do odpowiedniej lokalizacji. Pozostaje jeszcze wygląd linku. Jeśli nie wypełnisz 2 argumentu to Excel domyślnie przyjmie to co stworzyłeś w 1 argumencie, ale jeśli wpiszesz do argumentu przyjazna nazwa tekst lub odwołanie do komórki, to Excel właśnie to będzie wyświetlał, np nazwę arkusza:

=HIPERŁĄCZE("#"&B3&"!A1";B3)

P.S.

Jeśli chcesz dowiedzieć się więcej na temat Excela lub nie wiesz jak coś zrobić to napisz do mnie. Ja w miarę możliwości odpowiem na Twoje pytanie.

Excel i Adam - kontakt

Bezpośredni odnośnik do filmu na youtube — Łącza do wszystkich arkuszy — porada #133

Automatyczny zapis i autoodzyskiwanie pliku — porada #132

Jak szybko przemieszczać się między arkuszami?


Automatyczny zapis i autoodzyskiwanie pliku — porada #132

Automatyczny zapis i autoodzyskiwanie pliku - porada #132

W Excelu jest opcja automatycznego zapisywania zmian w pliku, ale standardowa wartość co 10 minut może być za długim okresem dla wielu użytkowników. Dlatego możesz ją zmienić:

Karta Plik — Opcje — zakładka zapisywanie

Znajduje się tu też lokalizacja, gdzie zapisywane są pliki przy nietypowych wyłączeniach się komputera, czyli np: przy gwałtownym odcięciu zasilania. Przeważnie przypomina tą ścieżkę:

C:\Users\akopec\AppData\Roaming\Microsoft\Excel\

Jeśli masz włączone pokazywanie ukrytych plików
(W eksploatorze windowsa naciśnij Alt, następnie N i wybierz Opcje folderów.. tam przeskocz na kartę widok i znajdź opcje Pokaż ukryte pliki i foldery)
to zobaczysz również tymczasowy plik obok pliku, który edytujesz.

P.S.

Jeśli chcesz dowiedzieć się więcej na temat Excela lub nie wiesz jak coś zrobić to napisz do mnie. Ja w miarę możliwości odpowiem na Twoje pytanie.

Excel i Adam - kontakt

Bezpośredni odnośnik do filmu na youtube — Automatyczny zapis i autoodzyskiwanie pliku — porada #132

Szybkie przemieszczanie się między arkuszami — porada #131

Jak szybko przemieszczać się między arkuszami?


Szybkie przemieszczanie się między arkuszami — porada #131

Szybkie przemieszczanie się między arkuszami - porada #131

W Excelu jest wiele sposobów na przemieszczanie się między arkuszami. Chyba najbardziej popularne jest po prostu kliknięcie na wybranym arkuszu. Bywa to jednak kłopotliwe jeśli mamy bardzo dużo arkuszy w naszym pliku.

Co prawda szybka możliwość przesunięcia listy arkuszy na początek lub koniec, a potem kliknięcie wybranego arkusza, jest pomocne, ale nie zawsze najwygodniejsze.

Często wygodne są skróty klawiszowe:
Ctrl + Page up — przeskoczenie do arkusza o 1 w prawo
Ctrl + Page down
— przeskoczenie do arkusza o 1 w lewo

Na koniec jeszcze możesz kliknąć na przyciski do przesuwania arkuszy prawym przyciskiem myszy i wtedy rozwinie się lista wszystkich arkuszy w pliku. Możesz przeskoczyć na dowolny z nich klikając w niego.

P.S.

Jeśli chcesz dowiedzieć się więcej na temat Excela lub nie wiesz jak coś zrobić to napisz do mnie. Ja w miarę możliwości odpowiem na Twoje pytanie.

Excel i Adam - kontakt

Bezpośredni odnośnik do filmu na youtube — Szybkie przemieszczanie się między arkuszami — porada #131

Lista wszystkich arkuszy — funkcja O.SKOROSZYCIE- porada #130

Jak za pomocą formuły znaleźć listę wszystkich nazw arkuszy?


Lista wszystkich arkuszy — funkcja O.SKOROSZYCIE- porada #130

Lista wszystkich arkuszy - funkcja O.SKOROSZYCIE- porada #130

Żeby uzyskać listę wszystkich arkuszy w pliku będziemy na początek wykorzystać formułę korzystającą z funkcji O.SKOROSZYCIE

Nie znajdziesz jej w pomocy Excela. Jest pozostałością po wcześniejszych wersjach programu i jest tzw. funkcją makr, czyli plik, w którym będziesz chciał ją zapisać będzie musiał obsługiwać makra, czyli np: miał rozszerzenie .xlsm

Formułę:
=ZASTĄP(O.SKOROSZYCIE(1);1;ZNAJDŹ("]";O.SKOROSZYCIE(1));"")

umieszczamy w menadżerze nazw i nadajemy mu nazwę np: ListaArkuszy

Teraz możemy się do tej nazwy odwoływać w komórkach i wyciągnąć poszczególne elementy np: za pomocą funkcji INDEKS

=INDEKS(ListaArkuszy;ILE.WIERSZY($B$3:B3))

Ta formuła ma wadę, bo nie uwzględnia ilości elementów, czyli arkuszy. Żeby policzyć ilość elementów zwracanych przez formułę z funkcją O.SKOROSZYCIE najwygodniej użyć prostej formuły:

=LICZBA.KOLUMN(ListaArkuszy)

ze względu, że każdy element na tej liście znajduje się w osobnej kolumnie. Świadczy o tym znak \ rozdzielający elementy, który w zapisie Excela oznacza nową kolumnę:

{"Arkusz1"\"Arkusz2"\"Arkusz3"}

Teraz możemy wprowadzić modyfikację do formuły, żeby jeśli przekroczymy ilość elementów na liście zwracała pusty ciąg znaków — ""

=JEŻELI(ILE.WIERSZY($B$3:B3) Większe niż $A$3;"";INDEKS(ListaArkuszy;ILE.WIERSZY($B$3:B3)))

P.S.

Jeśli chcesz dowiedzieć się więcej na temat Excela lub nie wiesz jak coś zrobić to napisz do mnie. Ja w miarę możliwości odpowiem na Twoje pytanie.

Excel i Adam - kontakt

Bezpośredni odnośnik do filmu na youtube — Lista wszystkich arkuszy — funkcja O.SKOROSZYCIE- porada #130