Jak za pomocą formuły znaleźć listę wszystkich nazw arkuszy?


Lista wszystkich arkuszy — funkcja O.SKOROSZYCIE- porada #130

Lista wszystkich arkuszy - funkcja O.SKOROSZYCIE- porada #130

Żeby uzyskać listę wszystkich arkuszy w pliku będziemy na początek wykorzystać formułę korzystającą z funkcji O.SKOROSZYCIE

Nie znajdziesz jej w pomocy Excela. Jest pozostałością po wcześniejszych wersjach programu i jest tzw. funkcją makr, czyli plik, w którym będziesz chciał ją zapisać będzie musiał obsługiwać makra, czyli np: miał rozszerzenie .xlsm

Formułę:
=ZASTĄP(O.SKOROSZYCIE(1);1;ZNAJDŹ("]";O.SKOROSZYCIE(1));"")

umieszczamy w menadżerze nazw i nadajemy mu nazwę np: ListaArkuszy

Teraz możemy się do tej nazwy odwoływać w komórkach i wyciągnąć poszczególne elementy np: za pomocą funkcji INDEKS

=INDEKS(ListaArkuszy;ILE.WIERSZY($B$3:B3))

Ta formuła ma wadę, bo nie uwzględnia ilości elementów, czyli arkuszy. Żeby policzyć ilość elementów zwracanych przez formułę z funkcją O.SKOROSZYCIE najwygodniej użyć prostej formuły:

=LICZBA.KOLUMN(ListaArkuszy)

ze względu, że każdy element na tej liście znajduje się w osobnej kolumnie. Świadczy o tym znak \ rozdzielający elementy, który w zapisie Excela oznacza nową kolumnę:

{"Arkusz1"\"Arkusz2"\"Arkusz3"}

Teraz możemy wprowadzić modyfikację do formuły, żeby jeśli przekroczymy ilość elementów na liście zwracała pusty ciąg znaków — ""

=JEŻELI(ILE.WIERSZY($B$3:B3) Większe niż $A$3;"";INDEKS(ListaArkuszy;ILE.WIERSZY($B$3:B3)))

P.S.

Jeśli chcesz dowiedzieć się więcej na temat Excela lub nie wiesz jak coś zrobić to napisz do mnie. Ja w miarę możliwości odpowiem na Twoje pytanie.

Excel i Adam - kontakt

Bezpośredni odnośnik do filmu na youtube — Lista wszystkich arkuszy — funkcja O.SKOROSZYCIE- porada #130