Jak zmieniać dane w nagłówkach tabeli?

Zmienne nazwy (języki) w nagłówkach tabeli — porada #191 Zmienne nazwy (języki) w nagłówkach tabeli - porada #191

W Excelu nie da się w nagłówkach tabel wstawić formuły, dlatego nie jest możliwe to co jest opisane w tytule filmu, ale można zrobić sztuczkę, która sprawi jakby nagłówki tabeli były zmienne.

Przede wszystkim trzeba przygotować języki jaki chcesz mieć w nagłówkach oraz dane dla poszczególnych języków w nagłówkach.

Przyda się też klejenie pola kombi z karty dewelopera, na którym będziemy wybierać języki.

Teraz w udawanych nagłówkach piszemy formułę:

=INDEKS(Dane!$A$1:$D$3;p191_k!$D$1;LICZBA.KOLUMN(p191_k!$A$3:A3))

A prawdziwy wierz nagłówków tabeli ukrywamy.

P.S.

Jeśli chcesz dowiedzieć się więcej na temat Excela lub nie wiesz jak coś zrobić to napisz do mnie. Ja w miarę możliwości odpowiem na Twoje pytanie.

Excel i Adam - kontakt

Bezpośredni odnośnik do filmu na youtube — Zmienne nazwy (języki) w nagłówkach tabeli — porada #191