Jak stworzyć wykres wodospadowy z ujemnymi wartościami?

Wykres wodospadowy z wartościami ujemnymi — porada #187 Wykres wodospadowy z wartościami ujemnymi - porada #187

Żeby zbudować wykres wodospadowy potrzeba odpowiednio przygotować dane. Z kolumny z wartościami zysku i strat trzeba ustalić wartość aktualną:

=SUMA($C$3:C3)

Następnie jeśli chcesz możesz zostawić sobie wartości brzegowe, czyli przed i po wyznaczonym okresie.

Następnie najważniejsze są podstawy, na których będą stały Zyski i Straty:

=JEŻELI(D3*D4<=0;0;JEŻELI(ORAZ(D3<=0;D4<=0);MAX(D3:D4);MIN(D3:D4)))

Później trzeba obliczyć wartość strat nad osią y:

=JEŻELI(ORAZ(D3>=0;D4>=0;C4<=0);-C4;JEŻELI(ORAZ(D3>=0;D4<=0;C4<=0);D3;0))

oraz zysku pod osią y:

=JEŻELI(ORAZ(C4>=0;D3<=0;D4<=0);-C4;JEŻELI(ORAZ(C4>=0;D3<=0;D4>=0);D3;0))

Dzięki tym wartościom łatwo obliczymy straty pod osią y:

=JEŻELI(C4<0;C4+G4;0)

oraz zyski nad osią y:

=JEŻELI(C4>0;C4+H4;0)

Później musisz wstawić wykres kolumnowy skumulowany na podstawie tych obliczeń.
Pomalować podstawy na brak wypełnienia,a pozostałe serie na taki kolor jaki chcesz.
Na koniec możesz jeszcze usunąć zbędne serie z legendy klikając na nie i klikając Delete.

P.S.

Jeśli chcesz dowiedzieć się więcej na temat Excela lub nie wiesz jak coś zrobić to napisz do mnie. Ja w miarę możliwości odpowiem na Twoje pytanie.

Excel i Adam - kontakt

Bezpośredni odnośnik do filmu na youtube — Wykres wodospadowy z wartościami ujemnymi — porada #187