Jak sumować staż kumulując dni w miesiące itd?

Sumowanie dni, miesięcy i lat stażu pracy — widzowie #59 Sumowanie dni, miesięcy i lat stażu pracy - widzowie #59

Dostałem zapytanie jak sumować staż pracy, który zapisany jest jako podzielone wartości liczba lat, miesięcy i dni w poszczególnych pracach i przy założeniu, że wartości łączyć w całości, czyli np: 30 dni daje pełen miesiąc, 12 miesięcy pełen rok.

Do obliczenia dni potrzebna była suma i funkcja MOD, żeby dawać tylko wartości niepełnych miesięcy:

=MOD(SUMA(C2:C4);30)

Później trzeba było w podobny sposób obliczać miesiące, tylko tu trzeba było jeszcze obliczać ile pełnych miesięcy wyszło z dni:

=MOD(SUMA(B2:B4)+ZAOKR.DÓŁ(SUMA(C2:C4)/30;0);12)

na koniec były lata, gdzie trzeba było łączyć miesiące:

=SUMA(A2:A4)+ZAOKR.DÓŁ((SUMA(B2:B4)+ZAOKR.DÓŁ(SUMA(C2:C4)/30;0))/12;0)

P.S.

Jeśli chcesz dowiedzieć się więcej na temat Excela lub nie wiesz jak coś zrobić to napisz do mnie. Ja w miarę możliwości odpowiem na Twoje pytanie.

Excel i Adam - kontakt

Bezpośredni odnośnik do filmu na youtube — Sumowanie dni, miesięcy i lat stażu pracy — widzowie #59