Jak losować elementy z różnymi wagami prawdopodobieństwa?

SUMA JEŻELI przy operacji na danych — porada #190 Wykres wodospadowy z wartościami ujemnymi - porada #187

SUMA.JEŻELI nie zadziała poprawnie (i funkcje jej tożsame), gdy musisz wykonać operację na danych (zakresie), żeby wyszukać warunki jeżeli. Przykładowo jeśli chcesz zrobić sumę tylko po sprzedaży z kwietnia (4 miesiąca), to jeśli z dat wyciągałbyś miesiące, to funkcja SUMA.JEŻELI nie przyjęła by tego argumentu, ponieważ nie byłby zakresem.

Dlatego w podobnych sytuacjach musisz wykorzystać inną funkcję. Np SUMA.ILOCZYNÓW wtedy porównujesz wynik obliczeń do kryterium MIESIĄC(A2:A12)=E1 i uzyskujesz tablicę PRAWDA i FAŁSZ. Niestety funkcja SUMA.ILOCZYNÓW nie rozumie ich dlatego trzeba je zamienić na 0 i 1. Najszybciej robi się to za pomocą podwójnego przeczenie (dwóch znaków minus).

–(MIESIĄC(A2:A12)=E1)

Wystarczy jeszcze do drugiego argumentu włożyć zakres, po którym chcemy sumować z warunkiem i już mamy poprawny wynik:

=SUMA.ILOCZYNÓW(–(MIESIĄC(A2:A12)=E1);B2:B12)

P.S.

Jeśli chcesz dowiedzieć się więcej na temat Excela lub nie wiesz jak coś zrobić to napisz do mnie. Ja w miarę możliwości odpowiem na Twoje pytanie.

Excel i Adam - kontakt

Bezpośredni odnośnik do filmu na youtube — SUMA JEŻELI przy operacji na danych — porada #190