Jak losować elementy z różnymi wagami prawdopodobieństwa?

Losowanie elementów z różnym prawdopodobieństwem — widzowie #57 Wykres wodospadowy z wartościami ujemnymi - porada #187

Żeby losować elementy z różnym prawdopodobieństwem potrzebujesz przede wszystkim ustalić stosunek prawdopodobieństw poszczególnych elementów np: że element A ma bazową szansę wylosowania 1, a element B ma szansę wylosowania 2, czyli element B będzie losowany 2 razy częściej.

Następnie należy wszystkie prawdopodobieństwa ustawić jako sumę bieżącą, przez sumę wszystkich prawdopodobieństw, czyli zaczynamy od 0, a następnie dodajemy kolejne prawdopodobieństwa, by uzyskać progi od 0 do 1

=SUMA($B$2:B2)/SUMA($B$2:$B$8)

teraz wystarczy określić pozycję (PODAJ.POZYCJĘ) wylosowanej wartości z funkcji LOS i wybrać ją z listy elementów pomiędzy którymi losujemy (funkcja INDEKS):

=INDEKS($A$2:$A$8;PODAJ.POZYCJĘ(LOS();$C$2:$C$8;1))

P.S.

Jeśli chcesz dowiedzieć się więcej na temat Excela lub nie wiesz jak coś zrobić to napisz do mnie. Ja w miarę możliwości odpowiem na Twoje pytanie.

Excel i Adam - kontakt

Bezpośredni odnośnik do filmu na youtube — Losowanie elementów z różnym prawdopodobieństwem — widzowie #57