W tym poście pokażemy jak zrobić podsumowanie danych na wykresie po wybranych grupach. Zadanie to wykonamy na podstawie przykładowych danych z rys. nr 1.

Rys. nr 1 – przykładowe dane

W tej poradzie omówimy rozwiązanie prostsze dla podsumowania danych po Sprzedaży i premii dla poszczególnych grup w całości. Otrzymamy wykres przedstawiony na rys. nr 2.

Rys. nr 2 – wykres podsumowania Sprzedaży i Premii

W kolejnym poście omówimy rozwiązanie bardziej skomplikowane, a wykres będzie się prezentował jak na rys. nr 3. Na tym wykresie będzie widoczny dodatkowy podział na poszczególnych pracowników.

Rys. nr 3 – wykres podsumowania Sprzedaży i Premii z podziałem na pracowników

W pierwszym etapie musimy sobie podsumować (pogrupować) nasze dane według grup A, B i C. W tym celu stworzymy osobną tabelkę z danymi pomocniczymi. Skorzystamy tutaj z funkcji SUMA.JEŻELI. Pierwszym argumentem funkcji jest zakres, czyli zakres z kolumny B zablokowany bezwzględnie, na podstawie którego będziemy sprawdzać nasze kryterium – nazwę zespołu ($B$2:$B$11). Zakres blokujemy bezwzględnie za pomocą klawisza F4. Kolejnym argumentem funkcji są kryteria, czyli dział, dla którego chcemy uzyskać sumę (komórka $F2, zablokowana bezwzględnie po kolumnie). Trzeci argument to suma_zakres, czyli kolumna z której chcemy zsumować dane. Tę formułę piszemy dla wartości Sprzedaży, więc odpowiednio musimy w tym argumencie zaznaczyć zakres z kolumny C (Sprzedaż). Chcemy napisać formułę, którą będziemy mogli przeciągnąć na wiersze poniżej ale również na kolumnę obok (dla Premii), dlatego zakres ten blokujemy bezwzględnie tylko po wierszach. Zakres ten będzie wyglądał następująco: C$2:C$11. Cała formuła powinna być zapisana w następujący sposób:

=SUMA.JEŻELI($B$2:$B$11;$F2;C$2:C$11)

Po zatwierdzeniu formuły, kopiujemy ją na wiersze poniżej. Otrzymamy wtedy podsumowanie Sprzedaży po poszczególnych działach. Następnie kopiujemy formułę na kolumnę obok. Otrzymamy wtedy podsumowanie Premii po poszczególnych działach (rys. nr 4). Zapis formuły automatycznie zmieni się tak, aby uwzględniał dane z kolumny Premia (zakres D$2:D$11), będzie się on prezentował następująco:

=SUMA.JEŻELI($B$2:$B$11;$F2;D$2:D$11)

Rys. nr 4 – tabelka zsumowanych danych Sprzedaży i Premii dla poszczególnych grup
Rys. nr 4 – tabelka zsumowanych danych Sprzedaży i Premii dla poszczególnych grup

W tym momencie pozostaje nam przedstawić te dane na wykresie. W tym celu zaznaczamy zakres całej tabeli (F1:H4) i rozwijamy ikonkę wykresu kolumnowego z karty Wstawianie, a następnie wybieramy pierwszą ikonkę wykresu z grupy Kolumnowy 2D (rys. nr 5).

Rys. nr 5 – polecenie wykresu kolumnowy 2D

Otrzymamy automatycznie stworzone wykres przedstawiony na rys. nr 6.

Rys. nr 6 – automatycznie wstawiony wykres kolumnowy

Teraz zajmiemy się edycją tego wykresu. Musimy zmienić jego tytuł, aby było jasne, czego dotyczy. Klikamy dwukrotnie na pole z Tytułem wykresu i wpisujemy nowy tytuł (Podsumowania Sprzedaży i Premii dla zespołów). Następnie możemy dopracować nasze kolumny na wykresie. Zaznaczamy taką kolumnę na wykresie, następnie za pomocą skrótu klawiszowego Ctrl+1, otwieramy okno Formatowania serii danych. Załóżmy, że chcemy aby Kolumny Sprzedaży stykała się z kolumną Premii. W tym celu w oknie Formatowania serii danych pasek Nakładania serii ustawiamy na 0% (rys. nr 7).

Rys. nr 7 – ustawienie Nakładania serii

Następnie możemy ustawić Szerokość odstępu, aby poszerzyć nasze kolumny. W naszym przykładzie ustawimy szerokość odstępu na 94% (rys. nr 8).Rys. nr 8 – ustawienie Szerokości odstępuNastępnie możemy ustawić Szerokość odstępu, aby poszerzyć nasze kolumny. W naszym przykładzie ustawimy szerokość odstępu na 94% (rys. nr 8).

Rys. nr 8 – ustawienie Szerokości odstępu

Po powyższych zmianach otrzymamy wykres przedstawiony na rys. nr 9.

Rys. nr 9 – wykres Podsumowania Sprzedaży i Premii dla zespołów

Podsumowując, jeśli mamy zrobić wykres podsumowania Sprzedaży i Premii jako całość dla poszczególnych grup, to wystarczy stworzyć tabelę pomocniczą z sumą tych danych, uzyskanych przy użyciu funkcji SUMA.JEŻELI.


Książka Mistrz Excela + promo na 35 urodziny

Chcę Cię poinformować, że w końcu udało mi zebrać środki i dopiąć wszystkich formalności, żeby powstało II wydanie mojej książki Mistrz Excela (zostałem wydawcą)
II wydanie jest wzbogacone o rozdział (nr 22) wprowadzający w genialny dodatek (Power Query) do Excela służący do pobierania, łączenia i wstępnej obróbki danych z wielu źródeł.

Książka Mistrz Excela to historia Roberta, który musi poznać dobrze Excela na potrzeby nowej pracy. Książka jest napisana w formie rozmów Roberta z trenerem, dzięki temu jest przystępniejsza w odbiorze niż standardowe książki techniczne pisane językiem "wykładowym".

Rozmowy zostały podzielone na 22 tematyczne rozdziały, które krok po kroku wprowadzają Cię w tajniki Excela. Robert zaczyna naukę od poznania ciekawych aspektów sortowania i filtrowania danych w Excelu, przechodzi przez formatowanie warunkowe, tabele przestawne, funkcje wyszukujące i wiele innych tematów, by na koniec poznać wstępne informacje o VBA i Power Query.
A wszystko to na praktycznych przykładach i z dużą ilością zdjęć.

Żebyś mógł śledzić postępy Roberta, do książki dołączone są pliki Excela, na których pracuje Robert.

Aktualnie w promocji urodzinowej możesz mieć Mistrza Excela w obniżonej cenie, jeśli tylko wpiszesz kod 35URODZINY
https://exceliadam.pl/produkt/ksiazka-mistrz-excela

Na powyższej stronie znajdziesz dokładniejszy opis książki, opinie osób, które kupiły I wydanie oraz podgląd pierwszego rozdziału książki, żeby upewnić się, czy forma rozmów przy nauce Excela jest dla Ciebie.
Jeśli książka Ci się spodoba poinformuj o niej swoich znajomych.

W ramach promocji na moje 35 urodziny możesz też mieć każdy z moich kursów wideo na Udemy za zaledwie 35 zł. Linki do kursów zamieszczam poniżej. W każdym kursie są udostępnione filmy do podglądu, byś mógł się przekonać czy dany kurs jest dla Ciebie.

Power Query
https://www.udemy.com/course/mistrz-power-query/?couponCode=35URODZINY

Mistrz Excela
https://www.udemy.com/mistrz-excela/?couponCode=35URODZINY

Dashboardy
https://www.udemy.com/course/excel-dashboardy/?couponCode=35URODZINY

Mistrz Formuł
https://www.udemy.com/course/excel-mistrz-formul/?couponCode=35URODZINY

VBA
https://www.udemy.com/course/excel-vba-makra/?couponCode=35URODZINY

Microsoft Power BI
https://www.udemy.com/course/power-bi-microsoft/?couponCode=35URODZINY

Książka Mistrz Excela reklama