W tym poście omówimy dokładnie działanie funkcji SUMA. Poznamy ciekawostki na jej temat i różne przykłady jej zastosowania. Zadanie to wykonamy na podstawie przykładowych danych z rys. nr 1.

Rys. nr 1 – przykładowe dane

W pierwszym zestawie danych mamy przedstawiony dochód z podziałem na poszczególne miesiące. Naszym celem jest zsumowanie dochodu ze wszystkich miesięcy. Użyjemy tutaj funkcji SUMA. Argumentami funkcji są liczba1, [liczba2], [liczba3…]. Argumenty wypisane po przecinkach mogą sugerować, że musimy tutaj podawać pojedyncze komórki. Jednak nie jest to konieczne, mianowicie prawidłowo zadziała zaznaczenie lub wpisanie ręcznie odpowiedniego zakresu. Zapis funkcji powinien wyglądać następująco:

=SUMA(B2,B3,B4:B13)

Po zatwierdzeniu formuły otrzymamy wynik przedstawiony na rys. nr 2.

Rys. nr 2 – suma dla podanego zakresu danych

Ze względu na to, że funkcja SUMA jest jedną z najczęściej wykorzystywanych w Excelu, doczekała się skrótu klawiszowego Alt+= (Alt+ znak równa się). Jeśli ustawimy aktywną komórkę, gdzie chcemy wstawić funkcję SUMA, a następnie skorzystamy ze skrótu klawiszowego Alt+=, Excel nie tylko wstawi funkcję SUMA, ale też sam ustawi odpowiedni zakres (rys. nr 3).

Rys. nr 3 – Automatyczne wstawienie zakresu do funkcji SUMA

W drugiej tabelce mamy zbliżone dane, ale mamy niepełne informacje. Mianowicie brakuje danych z trzech miesięcy (rys. nr 4).

Rys. nr 4 – niepełne dane

Jeśli ustawimy aktywną komórkę pod danymi i wciśniemy skrót klawiszowy Alt+=, to Excel automatycznie zaznaczy cały zakres danych, włącznie z komórkami z tekstem brak danych. Zapis funkcji będzie wyglądał następująco:

=SUMA(E2:E13)

Moglibyśmy ręcznie zaznaczyć odpowiedni zakres, który nie uwzględniałby komórek z brakiem danych. Jednak wtedy po wpisaniu brakujących danych, nie zostały by one uwzględnione w obliczeniach. Dlatego zostawiamy domyślny zakres. Excel bez problemu poradzi sobie z komórkami z tekstem w zakresie, po prostu ich nie doda. Po zatwierdzeniu formuły otrzymamy wynik przedstawiony na rys. nr 5.  Dzięki zaznaczeniu całego zakresu Excel bez problemu poradzi sobie z przeliczeniem sumy, kiedy dane z pozostałych miesięcy zostaną dopisane.

Rys. nr 5 – wynik sumy dla danych z komórkami tekstowymi

Dla nas istotne jest, że funkcja SUMA zignoruje komórki z tekstem czy z wartościami logicznymi PRAWDA lub FAŁSZ.

W trzeciej tabeli z danymi mamy tablicę, którą chcemy podsumować zarówno po wierszach jak i po kolumnach. W takiej sytuacji wystarczy najpierw zaznaczyć wypełniony zakres danych, dodatkowo kolumnę z prawej strony danych i wiersz pod spodem, a następnie skorzystać ze skrótu klawiszowego Alt+=. Excel automatycznie obliczy sumy dla poszczególnych wierszy i kolumn oraz sumę końcową dla tych wszystkich danych. Wyniku możemy obejrzeć na rys. nr 6.

Rys. nr 6 – sumy dla poszczególnych kolumn i wierszy oraz suma końcowa

W takiej sytuacji Excel wstawi w każdą komórkę tak jakby osobną formułę dla odpowiedniego dla danej komórki zakresu. I tak np. dla wyniku sumy z wiersza czwartego, mamy formułę =SUMA(H4:K4), co widać na rys. nr 7.

Rys. nr 7 – formuła SUMY dla czwartego wiersza

Analogicznie Excel zadziała dla kolumn, czyli dla każdej kolumny wpisze formułę z odpowiednim zakresem. I tak np. dla kolumny H, zapis formuły będzie wyglądał następująco: =SUMA(H2:H13).

Warto wspomnieć, że możemy zrobić zwykłe dodawanie. Wtedy nie używamy nazwy funkcji SUMA, a dodajemy poszczególne komórki łącząc je znakiem plus (+). W tej sytuacji możemy dodawać kilka liczb, ale jeśli w zwykłym dodawaniu spróbujemy dodać komórkę z tekstem, to Excel zwróci nam błąd (rys. nr 8). Zwykłe dodawanie zadziała prawidłowo, jeśli będziemy chcieli dodać wartości logiczne PRAWDA lub FAŁSZ. Wartości tekstowych Excel nie jest w stanie przekształcić, a wartości logiczne tak. Często w Excelu wartość logiczna FAŁSZ jest utożsamiana z wartością liczbową 0 (zero), a PRAWDA z wartością 1.

Rys. nr 8 – błąd dodawania

Jeśli zrobimy zwykle dodawanie z wartością logiczną PRAWDA otrzymamy wynik powiększony o 1. Natomiast jeśli użyjemy funkcji SUMA (z uwzględnieniem wartości logicznej PRAWDA), wartość ta zostanie pominięta.

Kolejną zaletą funkcji SUMA, jest sytuacja kiedy do zaznaczonego zakresu, chcemy dodać jakąś konkretną liczbę, to Excel bez problemu wykona takie działanie. W takie sytuacji zapis formuły wyglądał by następująco:

=SUMA(B2:B13;2000)

Ponadto dodatkowy dodawany argument może być tablicą. Wtedy też Excel poradzi sobie z takim obliczeniem. Zapis formuły może wtedy wyglądać następująco:

=SUMA(B2:B13;{2000;3000}

W obu omówionych powyżej otrzymamy prawidłowe wyniki dodawania.

Podsumowując, funkcja SUMA sumuje zakresy danych, ale w ograniczonej ilości (maksymalnie 255 zakresów). Jako jedyna z funkcji Excela ma przypisany skrót klawiszowy ALT+=.  Ponadto ignoruje wartości logiczne (PRAWDA i FAŁSZ) oraz tekst. Kolejnym atutem funkcji SUMA jest to, że dodaje do zakresów stałe wartości wpisane ręczne jako argumenty oraz tablice danych (rys. nr 9).

Rys. nr 9 – zalety funkcji SUMA

Książka Mistrz Excela + promo na 35 urodziny

Chcę Cię poinformować, że w końcu udało mi zebrać środki i dopiąć wszystkich formalności, żeby powstało II wydanie mojej książki Mistrz Excela (zostałem wydawcą)
II wydanie jest wzbogacone o rozdział (nr 22) wprowadzający w genialny dodatek (Power Query) do Excela służący do pobierania, łączenia i wstępnej obróbki danych z wielu źródeł.

Książka Mistrz Excela to historia Roberta, który musi poznać dobrze Excela na potrzeby nowej pracy. Książka jest napisana w formie rozmów Roberta z trenerem, dzięki temu jest przystępniejsza w odbiorze niż standardowe książki techniczne pisane językiem "wykładowym".

Rozmowy zostały podzielone na 22 tematyczne rozdziały, które krok po kroku wprowadzają Cię w tajniki Excela. Robert zaczyna naukę od poznania ciekawych aspektów sortowania i filtrowania danych w Excelu, przechodzi przez formatowanie warunkowe, tabele przestawne, funkcje wyszukujące i wiele innych tematów, by na koniec poznać wstępne informacje o VBA i Power Query.
A wszystko to na praktycznych przykładach i z dużą ilością zdjęć.

Żebyś mógł śledzić postępy Roberta, do książki dołączone są pliki Excela, na których pracuje Robert.

Aktualnie w promocji urodzinowej możesz mieć Mistrza Excela w obniżonej cenie, jeśli tylko wpiszesz kod 35URODZINY
https://exceliadam.pl/produkt/ksiazka-mistrz-excela

Na powyższej stronie znajdziesz dokładniejszy opis książki, opinie osób, które kupiły I wydanie oraz podgląd pierwszego rozdziału książki, żeby upewnić się, czy forma rozmów przy nauce Excela jest dla Ciebie.
Jeśli książka Ci się spodoba poinformuj o niej swoich znajomych.

W ramach promocji na moje 35 urodziny możesz też mieć każdy z moich kursów wideo na Udemy za zaledwie 35 zł. Linki do kursów zamieszczam poniżej. W każdym kursie są udostępnione filmy do podglądu, byś mógł się przekonać czy dany kurs jest dla Ciebie.

Power Query
https://www.udemy.com/course/mistrz-power-query/?couponCode=35URODZINY

Mistrz Excela
https://www.udemy.com/mistrz-excela/?couponCode=35URODZINY

Dashboardy
https://www.udemy.com/course/excel-dashboardy/?couponCode=35URODZINY

Mistrz Formuł
https://www.udemy.com/course/excel-mistrz-formul/?couponCode=35URODZINY

VBA
https://www.udemy.com/course/excel-vba-makra/?couponCode=35URODZINY

Microsoft Power BI
https://www.udemy.com/course/power-bi-microsoft/?couponCode=35URODZINY

Książka Mistrz Excela reklama