Jak wybrać cenę brutto lub netto?

Wybór cena netto brutto przecięcia niejawne — widzowie #60 Wybór cena netto brutto przecięcia niejawne - widzowie #60

Żeby wybrać kwotę netto lub brutto dla produktów, można śmiało posłużyć się odwołaniem do dwóch kolumn, które zawierają te ceny i tylko wybierać, z której kolumny chcemy cenę np przy pomocy funkcji PODAJ.POZYCJĘ. Łącząc to w całość może wystarczyć taka formuła:

=INDEKS(Ceny!$B$2:$C$11;;PODAJ.POZYCJĘ(Wybór!$D$1;Ceny!$B$1:$C$1;0))

Wykorzystuje ona przecięcia niejawne do określenia wiersza produktu. Jeśli nie chcesz ryzykować zmiany przecięć lepiej dołożyć jeszcze jedną funkcję PODAJ.POZYCJĘ by odnajdywała wiersz, w którym jest wybrany produkt:

=INDEKS(Ceny!$B$2:$C$11;PODAJ.POZYCJĘ(A2;Ceny!$A$2:$A$11;0);PODAJ.POZYCJĘ(Wybór!$D$1;Ceny!$B$1:$C$1;0))

P.S.

Jeśli chcesz dowiedzieć się więcej na temat Excela lub nie wiesz jak coś zrobić to napisz do mnie. Ja w miarę możliwości odpowiem na Twoje pytanie.

Excel i Adam - kontakt

Bezpośredni odnośnik do filmu na youtube — Wybór cena netto brutto przecięcia niejawne — widzowie #60