Jak sumować uwzględniając wiele kryteriów?


Sumowanie po wielu kryteriach SUMA.WARUNKÓW — pytania widzów #4

Roman miał tabelę z hurtowniami i ich zarobkami uporządkowanymi według dat. Robił sumę zysków dla poszczególnym hurtowni wykorzystując funkcję SUMA.JEŻELI. Jego funkcja miała taką strukturę:

SUMA.JEŻELI(Zakres z nazwami hurtowni; Nazwa hurtowni po której chce sumować; Zakres po którym będzie sumowane po sprawdzeniu warunków)

Ta struktura przekłada się na filmie w odwołania do odpowiednich komórek.

SUMA.JEŻELI(D3:D14;I2;E3:E14)

Tabela hurtowni i funkcja SUMA.JEŻELI

Tabela hurtowni i funkcja SUMA.JEŻELI

Ta funkcja sprawdzała się, gdy chciał sumować po jednym warunku (nazwie hurtowni), ale gdy zaszła potrzeba do tego dołożyć jeszcze daty, ta formuła nie dawała rady. Należało wykorzystać funkcję SUMA.WARUNKÓW. Ta funkcja pozwala na ustawienie wielu warunków jednocześnie.

Struktura funkcji SUMA.WARUNKÓW pozwala na ustawienie wielu warunków, zawsze ustawianych w pary z zakresami, to znaczy, że 1 parametrem funkcji jest zakres, po którym będzie liczona suma, a następnie podajesz parę:

  • zakres po którym sprawdzany ma być warunek,
  • warunek.

Te dwa parametry zawsze muszą być podawane w parze, a takich par możesz dodać bardzo dużo.

Przykładowy zapis dla sprawdzenia nazwy hurtowni i ustawienia daty pomiędzy 2012-11-01, a 2012-10-01 wygląda tak
=SUMA.WARUNKÓW(E3:E14;D3:D14;I2;B3:B14;"2012-11-01";B3:B14;">2012–10-01")

SUMA.WARUNKÓW daty wpisane ręcznie

SUMA.WARUNKÓW daty wpisane ręcznie

      1 parametr (E3:E14) to zakres, po którym będzie robiona suma,
      2 parametr (D3:D14) to zakres, po którym będzie sprawdzany 1 warunek (nazwa hurtowni),
      3 parametr (I2) to nazwa hurtowni, po którym będzie sprawdzany 1 zakres,
      4 parametr (B3:B14) to zakres, po którym będzie sprawdzany 2 warunek (mniejsze od daty, czyli wcześniej niż data),
      5 parametr ("2012-11-01") to odpowiednio znak mniejszości i data w cudzysłowie, po której będzie przeszukiwany 2 zakres, 
      6 parametr (B3:B14) to zakres, po którym będzie sprawdzany 3 warunek (mniejsze od daty, czyli wcześniej niż data),
      7 parametr (">2012–10-01") to odpowiednio znak mniejszości i data w cudzysłowie, po której będzie przeszukiwany 3 zakres. 

W podobny sposób możesz dodawać kolejne warunki — zawsze w parach — zakres_sprawdzania_warunku i warunek

Możesz zauważyć, że w przykładzie powyżej 3 parametr jest zapisany jako odwołanie do komórki, a 5 i 7 parametr są wpisane z cudzysłowach. Jeżeli chciałbyś, żeby były one pokazane jako odwołania do komórek powinny wyglądać odpowiednio tak:
""&J6 i ">"&J7
czyli połączenie (&) znaku mniejsze lub większe w cudzysłowie z odwołaniem do komórki

Cała formuła wtedy wygląda odpowiednio:

=SUMA.WARUNKÓW(E3:E14;D3:D14;I2;B3:B14;""&J6;B3:B14;">"&J7)

SUMA.WARUNKÓW daty pobierane z komórek

SUMA.WARUNKÓW daty pobierane z komórek

P.S.

Jeśli chcesz dowiedzieć się więcej na temat Excela lub nie wiesz jak coś zrobić do mnie o tym w komentarzu pod spodem albo napisz do mnie bezpośrednio, ja w miarę możliwości odpowiem na Twoje pytanie.

Excel i Adam - kontakt

Bezpośredni odnośnik do filmu na youtube — Sumowanie po wielu kryteriach SUMA.WARUNKÓW — pytania widzów #4