Jak ustawić wynik przy ostatnim wystąpieniu kontrahenta?

Licznik faktur przy ostatnim wystąpieniu kontrahenta — widzowie #58 Licznik faktur przy ostatnim wystąpieniu kontrahenta -  widzowie #58

Pytanie widza polegało na tym, że pewne obliczenia (liczbę faktur dla danego kontrahenta) pokazać tylko przy ostatnim wystąpieniu tego kontrahenta.

Samo obliczenie liczby faktur załatwia się przeważnie korzystając z zakresów dynamicznych, które mają jeden koniec zablokowany, a drugi ruchomy.

=LICZ.WARUNKI($D$2:D2;D2;$C$2:C2;"faktura")

Trzeba było jeszcze wykorzystać funkcję JEŻELI, żeby sprawdzać warunek czy to ostatnie wystąpienie kontrahenta. Tu też można wykorzystać dynamiczne tylko zmniejszające się, czyli od pierwszego wiersza do wiersza bardzo daleko np: D2:$D$1000 w sumie daje to taką formułę:

=JEŻELI(LICZ.JEŻELI(D2:$D$1000;D2)>1;"";LICZ.WARUNKI($D$2:D2;D2;$C$2:C2;"faktura"))

P.S.

Jeśli chcesz dowiedzieć się więcej na temat Excela lub nie wiesz jak coś zrobić to napisz do mnie. Ja w miarę możliwości odpowiem na Twoje pytanie.

Excel i Adam - kontakt

Bezpośredni odnośnik do filmu na youtube — Licznik faktur przy ostatnim wystąpieniu kontrahenta — widzowie #58