Dzisiaj chcemy zsumować wartości z całego wiersza na podstawie pojedynczego kryterium. Czyli przykładowo jeśli wybierzemy Tadeusza to chcemy zsumować 3 wartości (cały wiersz).

Porada 291 - Sumowanie całego wiersza na podstawie pojedynczego kryterium 01

Problem jest taki, że SUMA.JEŻELI, z której najczęściej korzystamy, gdy chcemy zsumować wartości po warunku nie zadziała tu poprawnie:

=SUMA.JEŻELI(A3:A9;G1;B3:D9)

Wynika to ze sposobu działania funkcji SUMA.JEŻELI – na 1 komórkę, która spełnia warunek funkcja SUMA.JEŻELI zsumuje 1 komórkę z zakresu podanego do sumowania. Dlatego tutaj musimy skorzystać z innej formuły.
Odpowiednią możliwość daje nam SUMA.ILOCZYNÓW z odpowiednimi obliczeniami w argumencie.

Zaczniemy od tego, że potrzebujemy sprawdzić warunki, czyli prosta operacja porównania A3:A9=G1. Następnie tą wartość musimy (wciąż wewnątrz funkcji) przemnożyć przez cały zakres danych do zsumowania (A3:A9=G1)*B3:D9

Wtedy dla każdej wartości PRAWDA z operacji porównania zostanie przemnożony cały wiersz z drugiego zakresu – po ewaluacji (klawisz F9), będzie to taki wynik w argumencie funkcji

SUMA.ILOCZYNÓW: {0\0\0;193\148\276;0\0\0;0\0\0;0\0\0;0\0\0;0\0\0}

Porada 291 - Sumowanie całego wiersza na podstawie pojedynczego kryterium 03

Funkcja SUMA.ILOCZYNÓW bez problemu sumuje wszystkie wartości z takiej tablicy i uzyskujemy poprawny wynik, czyli sumę wartości z każdego wiersza, dla którego zostanie spełnione kryterium w pierwszej kolumnie.

=SUMA.ILOCZYNÓW((A3:A9=G1)*B3:D9)

Porada 291 - Sumowanie całego wiersza na podstawie pojedynczego kryterium 04

Pozdrawiam
Adam Kopeć
Miłośnik Excela
Microsoft MVP