Mamy taką sytuację, że sprzedaż poszczególnych sprzedawców mamy w osobnych kolumnach i każdy sprzedawca sprzedaje różne produkty w różnej ilości.

Porada 290 - SUMA.JEŻELI po zakresie 2D 01

Chcemy mieć możliwość zsumowania ilości sprzedaży dowolnego wybranego produktu za pomocą jednej formuły. Można to zrobić za pomocą funkcji SUMA.JEŻELI – trzeba tylko wiedzieć dokładnie jak ona działa.

Zacznijmy od tego, że wybierzemy sobie produkt powiedzmy kokos. Dołożone formatowanie warunkowe zaznaczy odpowiednie pozycje.

Porada 290 - SUMA.JEŻELI po zakresie 2D 02

Łatwo zauważyć, że zawsze chcemy sumować wartość z komórki o jedną kolumnę na prawo od komórki z kokosem. Jak możemy coś takiego zrobić za pomocą funkcji SUMA.JEŻELI?

Zaczniemy od tego, że poniżej naszych danych napiszemy prostą operację porównania przyrównującą wartość komórki do wybranego produktu. Dodatkowo pomalujemy komórki obok komórek z prawdami, bo to z nich tak naprawdę chcemy wziąć wartości do sumowania.

=A3=$K$1

Porada 290 - SUMA.JEŻELI po zakresie 2D 03

Dzięki temu widzimy jaką macierz/tablicę zbuduje sobie funkcja SUMA.JEŻELI. To będą pojedyncze komórki z wartością logiczną PRAWDA tam, gdzie warunek został spełniony. W takim razie jak zsumować wartości, które są obok wartości PRAWDA? To proste – wystarczy, że odpowiednio przesuniemy zakres, po którym będziemy sumować w odniesieniu do zakresu sprawdzającego wartości.
Czyli nasza funkcja SUMA.JEŻELI powinna wglądać tak:

=SUMA.JEŻELI(A3:G9;K1;B3:H9)

Porada 290 - SUMA.JEŻELI po zakresie 2D 04

Czyli zakres, po którym sumujemy musimy być odpowiednio przesunięty w stosunku do zakresu, po którym sprawdzamy kryterium. W tym przykładzie jest to dokładnie 1 kolumna w prawo: A3:G9 -> B3:H9.

Pozdrawiam
Adam Kopeć
Miłośnik Excela
Microsoft MVP