Jak podzielić długą listę na wiele małych list?

Dostałem pytanie, czy istnieje funkcja, którą da się przekształcić długą listę (tak 100 000 elementów) na mniejsze listy każda w osobnej kolumnie.

Wielka lista na małe listy

Wielka lista na małe listy


Podział długiej listy na mniejsze – widzowie #9

Pojedynczej funkcji nie znam, ale udało mi się stworzyć prostą formułę.

Zaczynamy od funkcji INDEKS. Pozwala ona łatwo wybrać element z listy, trzeba tylko podać odpowiedni numer tego elementu i to jest tutaj najtrudniejszą częścią, żeby dobrze zapisać kolejne kolumny.

Zacznijmy od numeru wiersza, czyli wykorzystuję funkcję WIERSZ:

=INDEKS($A$1:$A$100000;WIERSZ(A1))

Ta formuła zwróci 1 element z długiej listy, ponieważ odwołuje się do komórki (A1), która jest w pierwszym wierszu. Jak będziesz ją przeciągać w dół, to będzie się odpowiednio zwiększał numer wiersza i będą zwracane kolejne elementy, 2, 3, itd.

Wybieranie elementów do list tylko z funkcją WIERSZ

Wybieranie elementów do list tylko z funkcją WIERSZ

Problem polega na tym, że jak będę ją kopiował do kolejnych kolumn nie będzie się zmieniać lista elementów, które będą zwracane, dlatego przyda się liczenie kolumn. Tu też można zacząć od komórki A1. Funkcja NR.KOLUMNY zwróci dla tej komórki wartość 1, a jak będziesz tą formułę przesuwał w prawo będzie ta wartość będzie rosła, wraz z numerem kolumny:

      kolumna B – 2
      kolumna C – 3
      itd.

Ponieważ w pierwszej kolumnie nowych list nie chce mieć jeszcze przesunięcia, to potrzebuje odjąć jedynkę, a wynik odejmowania pomnożyć przez wielkość list (np: 100)

=INDEKS($A$1:$A$100000;WIERSZ(A1)+(NR.KOLUMNY(A1)-1)*100)

Prawidłowa formuła dla przykładowej listy

Prawidłowa formuła dla przykładowej listy

Teraz tą formułę wystarczy przeciągnąć na odpowiedni obszar w dół i w prawo. Dla całej też dużej listy, będzie to obszar C1:ALN100

P.S.

Jeśli chcesz dowiedzieć się więcej na temat Excela lub nie wiesz jak coś zrobić do mnie o tym w komentarzu pod spodem albo napisz do mnie bezpośrednio, ja w miarę możliwości odpowiem na Twoje pytanie.

Excel i Adam - kontakt

Bezpośredni odnośnik do filmu na youtube – Podział długiej listy na mniejsze – widzowie #9