Wiodące zera – porada #193

Jak dołożyć wiodące zera na początku liczby?

Wiodące zera – porada #193 Wiodące zera - porada #193

Żeby uzyskać wiodące zera możesz zacząć pisać wartość od pojedynczego cudzysłowu ‚ a następnie piszesz liczbę zer, które potrzebujesz.

Drugim rozwiązaniem jest to, że nadasz komórce odpowiednie formatowanie niestandardowe np: 00000 (5 zer), wtedy każda liczba, która ma mniej cyfr niż 5 zostanie z przodu uzupełniona o zera.

Ważna różnica pomiędzy tymi rozwiązaniami jest to, że przy pierwszym szybko i łatwo możesz kontrolować liczbę zer na początku, ale liczba zostanie zamieniona na tekst w rozumieniu Excela i w pewnych sytuacjach nie będzie jej sumował jak np: w funkcji SUMA.
Drugie rozwiązanie pozostawia liczbę dalej liczbą i funkcja SUMA bez problemu ją sumuje.

P.S.

Jeśli chcesz dowiedzieć się więcej na temat Excela lub nie wiesz jak coś zrobić to napisz do mnie. Ja w miarę możliwości odpowiem na Twoje pytanie.

Excel i Adam - kontakt

Bezpośredni odnośnik do filmu na youtube – Wiodące zera – porada #193

Jak ukryć pasek arkuszy – porada #192

Jak ukryć karty arkuszy?

Jak ukryć pasek arkuszy – porada #192 Jak ukryć pasek arkuszy - porada #192

Żeby ukryć pasek arkuszy potrzebujesz wejść w menu Plik, następnie Opcje – Zaawansowane i w sekcji Opcje wyświetlania dla tego skoroszytu odznaczyć opcję Pokaż karty arkuszy.

Istotne jest, to że dalej będziesz mógł przeskakiwać pomiędzy arkuszami skrótami klawiszowymi Ctrl + Page Up lub Ctrl + Page Down, ale nie będziesz widział paska arkuszy w pasku na dole.

Robisz tam głównie wtedy, gdy chcesz, żeby użytkownik docelowy korzystał z menu, które dla niego przygotowałeś.

P.S.

Jeśli chcesz dowiedzieć się więcej na temat Excela lub nie wiesz jak coś zrobić to napisz do mnie. Ja w miarę możliwości odpowiem na Twoje pytanie.

Excel i Adam - kontakt

Bezpośredni odnośnik do filmu na youtube – Jak ukryć pasek arkuszy – porada #192

Zmienne nazwy (języki) w nagłówkach tabeli – porada #191

Jak zmieniać dane w nagłówkach tabeli?

Zmienne nazwy (języki) w nagłówkach tabeli – porada #191 Zmienne nazwy (języki) w nagłówkach tabeli - porada #191

W Excelu nie da się w nagłówkach tabel wstawić formuły, dlatego nie jest możliwe to co jest opisane w tytule filmu, ale można zrobić sztuczkę, która sprawi jakby nagłówki tabeli były zmienne.

Przede wszystkim trzeba przygotować języki jaki chcesz mieć w nagłówkach oraz dane dla poszczególnych języków w nagłówkach.

Przyda się też klejenie pola kombi z karty dewelopera, na którym będziemy wybierać języki.

Teraz w udawanych nagłówkach piszemy formułę:

=INDEKS(Dane!$A$1:$D$3;p191_k!$D$1;LICZBA.KOLUMN(p191_k!$A$3:A3))

A prawdziwy wierz nagłówków tabeli ukrywamy.

P.S.

Jeśli chcesz dowiedzieć się więcej na temat Excela lub nie wiesz jak coś zrobić to napisz do mnie. Ja w miarę możliwości odpowiem na Twoje pytanie.

Excel i Adam - kontakt

Bezpośredni odnośnik do filmu na youtube – Zmienne nazwy (języki) w nagłówkach tabeli – porada #191

Licznik faktur przy ostatnim wystąpieniu kontrahenta – widzowie #58

Jak ustawić wynik przy ostatnim wystąpieniu kontrahenta?

Licznik faktur przy ostatnim wystąpieniu kontrahenta – widzowie #58 Licznik faktur przy ostatnim wystąpieniu kontrahenta -  widzowie #58

Pytanie widza polegało na tym, że pewne obliczenia (liczbę faktur dla danego kontrahenta) pokazać tylko przy ostatnim wystąpieniu tego kontrahenta.

Samo obliczenie liczby faktur załatwia się przeważnie korzystając z zakresów dynamicznych, które mają jeden koniec zablokowany, a drugi ruchomy.

=LICZ.WARUNKI($D$2:D2;D2;$C$2:C2;”faktura”)

Trzeba było jeszcze wykorzystać funkcję JEŻELI, żeby sprawdzać warunek czy to ostatnie wystąpienie kontrahenta. Tu też można wykorzystać dynamiczne tylko zmniejszające się, czyli od pierwszego wiersza do wiersza bardzo daleko np: D2:$D$1000 w sumie daje to taką formułę:

=JEŻELI(LICZ.JEŻELI(D2:$D$1000;D2)>1;””;LICZ.WARUNKI($D$2:D2;D2;$C$2:C2;”faktura”))

P.S.

Jeśli chcesz dowiedzieć się więcej na temat Excela lub nie wiesz jak coś zrobić to napisz do mnie. Ja w miarę możliwości odpowiem na Twoje pytanie.

Excel i Adam - kontakt

Bezpośredni odnośnik do filmu na youtube – Licznik faktur przy ostatnim wystąpieniu kontrahenta – widzowie #58

Tab order czyli kolejność przeskakiwania między elementami na formularzu

Jak ustawić kolejność przeskakiwania pomiędzy elementami formularza?

Tab order czyli kolejność przeskakiwania między elementami na formularzu Tab order czyli kolejność przeskakiwania między elementami na formularzu

Kiedy tworzysz w Excelu VBA formularz i dodajesz do niego kolejne elementy, to chciałbyś, żeby kiedy naciskasz przycisk Tab przeskoki następowały w konkretnej kolejności (najczęściej z góry na dół).
Ale nie zawsze udaje się to zrobić od początki, ponieważ najpierw Excel VBA bazuje na kolejności w jakiej dodawałeś elementy.

Co prawda każdy poszczególny element ma własność TabIndex, ale zmieniając tą wartość dla pojedynczego elementu nie masz pewności jak zachowają się inne elementy. Dlatego dużo wygodniej w edytorze VBA otworzyć menu View i wybrać opcję Tab Order (kiedy masz aktywny wybrany formularz).

Otworzy się okienko z wszystkimi elementami wybranego formularza. Możesz przesuwać teraz ich kolejność góra (przycisk Move Up) i dół (przycisk Move Down).

Jak ustawisz właściwą kolejność możesz włączyć formularz i zobaczyć jak naciskając Tab przeskakujesz pomiędzy elementami formularza w wybranej kolejności.

Pewne elementy jak Label nie biorą udziału w tym przeskakiwaniu, mimo że można im ustawić własność TabIndex i pojawiają się w oknie Tab Order.

P.S.

Jeśli chcesz dowiedzieć się więcej na temat Excela lub nie wiesz jak coś zrobić to napisz do mnie. Ja w miarę możliwości odpowiem na Twoje pytanie.

Excel i Adam - kontakt

Bezpośredni odnośnik do filmu na youtube – Tab order czyli kolejność przeskakiwania między elementami na formularzu