Obraz jako komentarz — efekt wyskakującego obrazka — porada #203

Jak ustawić wyskakujący obrazek w komentarzu?

Obraz jako komentarz — efekt wyskakującego obrazka — porada #203 Obraz jako komentarz - efekt wyskakującego obrazka - porada #203

Żeby dodać obrazek jako komentarz trzeba zacząć od dodania komentarza do komórki (skrót klawiszowy Shift + F2).

Następnie wykasować cały tekst, zaznaczyć krawędź komentarza i nacisnąć Ctrl + 1.

Następnie zakładkę Kolory i linie, rozwinąć listę Kolor i wybrać pozycję Efekty wypełnienia. Przejść na zakładkę Obraz nacisnąć przycisk Wybierz obraz i wybrać obraz, a potem już tylko zatwierdzić wybór i masz obraz jako komentarz, czyli też wyskakujący obrazek, za każdym razem jak najedziesz na komórkę.

P.S.

Jeśli chcesz dowiedzieć się więcej na temat Excela lub nie wiesz jak coś zrobić to napisz do mnie. Ja w miarę możliwości odpowiem na Twoje pytanie.

Excel i Adam - kontakt

Bezpośredni odnośnik do filmu na youtube — Obraz jako komentarz — efekt wyskakującego obrazka — porada #203

Pokazywanie linii serii na wykresie za pomocą pola wyboru — porada #202

Jak ustawić by zmiana pola wyboru ukrywała i pokazywała serię danych na wykresie?

Pokazywanie linii serii na wykresie za pomocą pola wyboru — porada #202 Pokazywanie linii serii na wykresie za pomocą pola wyboru - porada #202

Żeby stworzyć wykres, którego linie (serie) pokazują się w zależności od tego, czy są zaznaczone pola wyboru czy nie trzeba w pierwszej kolejności odpowiednio przygotować dane.

Po pierwsze do nagłówków przyda się dodać na koniec kilka spacji, żeby były dłuższe i dzięki temu bez problemu uda się zmieścić pola wyboru obok serii legendy.

Dalej trzeba dodać 2 pola wyboru i połączyć ich stan (zaznaczone/odznaczone) z wartością PRAWDA/FAŁSZ w wybranej komórce. Na tej podstawie określamy, czy w kolumnie danych będzie pojawiać się właściwa dana, czy wartość funkcji BRAK. Dzięki temu dane będą się pojawiać gdy pole wyboru będzie zaznaczone, a znikać, gdy będzie odznaczone.

=JEŻELI(WykresGotowy!C$2;p202_koniec!B3;BRAK())

Trzeba teraz wstawić wykres. Przenieść legendę na górę wykresu. Przeciągnąć pola wyboru nad wykresem (jakby wykres je przykrywał trzeba przesunąć go na spodnią warstwę).

Warto jeszcze zaznaczyć pola wyboru i wykres, a następnie je pogrupować, by przenosiły się razem.

Zostaje jeszcze ustawienie wartości minimalnej i maksymalnej osi y, by nie zmieniała się jak odznaczysz wszystkie serie.

P.S.

Jeśli chcesz dowiedzieć się więcej na temat Excela lub nie wiesz jak coś zrobić to napisz do mnie. Ja w miarę możliwości odpowiem na Twoje pytanie.

Excel i Adam - kontakt

Bezpośredni odnośnik do filmu na youtube — Pokazywanie linii serii na wykresie za pomocą pola wyboru — porada #202

Odnalezienie kodu sklepu, po wyborze dostawcy i jego oznaczeniu sklepu — widzowie #62

Jak odnaleźć kod sklepu na podstawie dystrybutora i jego kodu sklepu?

Odnalezienie kodu sklepu, po wyborze dostawcy i jego oznaczeniu sklepu — widzowie #62 Odnalezienie kodu sklepu, po wyborze dostawcy i jego oznaczeniu sklepu - widzowie #62

Mamy taką sytuację, że mamy różnych dystrybutorów do różnych sklepów i każdy z tych dystrybutorów ma różne oznaczenie sklepów. Różne również od naszego i na podstawie tych oznaczeń chcemy znaleźć nasz kod sklepu.

Potrzebujemy odpowiednio ułożyć dane. Później w pierwszej kolejności musimy wybrać listę kodów wybranego dystrybutora. Możemy to zrobić funkcją INDEKS, której nie podamy 2 argumentu, dzięki czemu wyciągniemy całą kolumnę z kodami danego dystrybutora.

=INDEKS($B$3:$D$12;;PODAJ.POZYCJĘ($G$2;$B$2:$D$2;0))

Teraz z tej listy możemy znaleźć pozycję wybranego kodu dla dystrybutora:

=PODAJ.POZYCJĘ($G$3;INDEKS($B$3:$D$12;;PODAJ.POZYCJĘ($G$2;$B$2:$D$2;0));0)

Na podstawie tej pozycji możemy wyciągnąć nasz kod z listy.

=INDEKS($E$3:$E$12;PODAJ.POZYCJĘ($G$3;INDEKS($B$3:$D$12;;PODAJ.POZYCJĘ($G$2;$B$2:$D$2;0));0))

Ewentualnie przyda się funkcja JEŻELI.BŁĄD, żeby nie pokazywały się błędy.

=JEŻELI.BŁĄD(INDEKS($E$3:$E$12;PODAJ.POZYCJĘ($G$3;INDEKS($B$3:$D$12;;PODAJ.POZYCJĘ($G$2;$B$2:$D$2;0));0));“Niepoprawne dane”)

P.S.

Jeśli chcesz dowiedzieć się więcej na temat Excela lub nie wiesz jak coś zrobić to napisz do mnie. Ja w miarę możliwości odpowiem na Twoje pytanie.

Excel i Adam - kontakt

Bezpośredni odnośnik do filmu na youtube — Odnalezienie kodu sklepu, po wyborze dostawcy i jego oznaczeniu sklepu — widzowie #62

Sortowanie najpierw po liczbach parzystych potem nieparzystych — widzowie #61

Jak posortować po liczbach parzystych, a potem nieparzystych?

Sortowanie najpierw po liczbach parzystych potem nieparzystych — widzowie #61 Sortowanie najpierw po liczbach parzystych potem nieparzystych - widzowie #61

Żeby posortować najpierw po liczbach parzystych potem nieparzystych przyda się kolumna pomocnicza z następującą formułą

=MOD(A2;2)

która zwraca resztę z dzielenia przez 2.

Teraz wystarczy posortować najpierw kolumnę z wynikami funkcji MOD (reszty dzielenia), a potem kolumny z liczbami i uzyskamy żądany efekt.

P.S.

Jeśli chcesz dowiedzieć się więcej na temat Excela lub nie wiesz jak coś zrobić to napisz do mnie. Ja w miarę możliwości odpowiem na Twoje pytanie.

Excel i Adam - kontakt

Bezpośredni odnośnik do filmu na youtube — Sortowanie najpierw po liczbach parzystych potem nieparzystych — widzowie #61

Wybór cena netto brutto przecięcia niejawne — widzowie #60

Jak wybrać cenę brutto lub netto?

Wybór cena netto brutto przecięcia niejawne — widzowie #60 Wybór cena netto brutto przecięcia niejawne - widzowie #60

Żeby wybrać kwotę netto lub brutto dla produktów, można śmiało posłużyć się odwołaniem do dwóch kolumn, które zawierają te ceny i tylko wybierać, z której kolumny chcemy cenę np przy pomocy funkcji PODAJ.POZYCJĘ. Łącząc to w całość może wystarczyć taka formuła:

=INDEKS(Ceny!$B$2:$C$11;;PODAJ.POZYCJĘ(Wybór!$D$1;Ceny!$B$1:$C$1;0))

Wykorzystuje ona przecięcia niejawne do określenia wiersza produktu. Jeśli nie chcesz ryzykować zmiany przecięć lepiej dołożyć jeszcze jedną funkcję PODAJ.POZYCJĘ by odnajdywała wiersz, w którym jest wybrany produkt:

=INDEKS(Ceny!$B$2:$C$11;PODAJ.POZYCJĘ(A2;Ceny!$A$2:$A$11;0);PODAJ.POZYCJĘ(Wybór!$D$1;Ceny!$B$1:$C$1;0))

P.S.

Jeśli chcesz dowiedzieć się więcej na temat Excela lub nie wiesz jak coś zrobić to napisz do mnie. Ja w miarę możliwości odpowiem na Twoje pytanie.

Excel i Adam - kontakt

Bezpośredni odnośnik do filmu na youtube — Wybór cena netto brutto przecięcia niejawne — widzowie #60