Odwałania 3D czyli suma po wielu arkuszach — porada #157

Jak budować odwołania 3D?


Odwałania 3D czyli suma po wielu arkuszach — porada #157

Odwałania 3D czyli suma po wielu arkuszach - porada #157

Odwołania 3D to takie odwołania, które odwołują się do komórek z kilku arkuszy jednocześnie. Istotne jest, że te arkusze muszą ze sobą sąsiadować, więc nie jesteś w stanie stworzyć odwołania 3D, które będzie się odnosić do rozdzielonych arkuszy. Co najwyżej będzie to wtedy kilka odwołań 3D.

Przykładowe odwołanie 3D może wyglądać tak:

‘Dolnośląskie:Zachodniopomorskie’!B6

Oznacza ono, że odwołujemy się cały czas do komórki B6 ze wszystkich arkuszy od arkusza Dolnośląskie do Zachodniopomorskie.

Czasami przy odwołania 3D potrzeba włożyć nazwy arkuszy w pojedyncze cudzysłowy ’ gdy występują w nich znaki specjalne takie jak spacja, nawiasy i często polskie znaki.

Przy odwołania 3D działa względność i bezwzględność, czyli powyższy przykład jest odwołaniem względnym, które będzie się przesuwać wraz z kopiowaniem formuły w pionie i poziomie.

P.S.

Jeśli chcesz dowiedzieć się więcej na temat Excela lub nie wiesz jak coś zrobić to napisz do mnie. Ja w miarę możliwości odpowiem na Twoje pytanie.

Excel i Adam - kontakt

Bezpośredni odnośnik do filmu na youtube — Odwałania 3D czyli suma po wielu arkuszach — porada #157

Wyszukiwanie kolumna po kolumnie — porada #156

Jak wyszukiwać kolumna po kolumnie?


Wyszukiwanie kolumna po kolumnie — porada #156

Wyszukiwanie kolumna po kolumnie - porada #156

Żeby wyszukiwać dane w Excelu najczęściej korzysta się z funkcji WYSZUKAJ.PIONOWO. Standardowy zapis to np:

=WYSZUKAJ.PIONOWO($A$2;$A$5:$E$11;2;0)

Jest z nim problem jeśli szukamy kilku kolumn znajdujących się obok siebie, bo jeśli przeciągniemy ją w prawo, to ciągle będzie wyszukiwać 2 kolumną z tabeli danych, a my chcielibyśmy wyszukiwać 3, 4, itd… Oczywiście można pozmieniać numer kolumn w skopiowanych formułach, ale mój czytelnik Michał zaproponował inne rozwiązanie napisania formuły:

=WYSZUKAJ.PIONOWO(A2;A5:$E$11;2;0)

Ta formuła zadziała, gdy szukamy kolumna po kolumnie, ponieważ przesuwając się w prawo, szuka elementu już wyszukanego, na obszarze zmniejszonym o pierwszą kolumnę.

P.S.

Jeśli chcesz dowiedzieć się więcej na temat Excela lub nie wiesz jak coś zrobić to napisz do mnie. Ja w miarę możliwości odpowiem na Twoje pytanie.

Excel i Adam - kontakt

Bezpośredni odnośnik do filmu na youtube — Wyszukiwanie kolumna po kolumnie — porada #156

Ile razy pod rząd pojawia się wartość — porada #155

Jak obliczyć ile razy pod rząd wystąpiła wartość?


Ile razy pod rząd pojawia się wartość — porada #155

Ile razy pod rząd pojawia się wartość - porada #155

Jak obliczyć ile razy pod rząd pojawia się dana wartość na liście?
Można jako wykorzystać do tego funkcję CZĘSTOŚĆ i odpowiednio obliczone argumenty.

w parametrze dane będziemy sprawdzać czy znaleźliśmy szukaną wartość

=JEŻELI($A$2:$A$21=$E2;WIERSZ($A$2:$A$21))

jeśli tak to wpisujemy numer wiersza jeśli nie to FAŁSZ (odpowiedni argument JEŻELI pozostaje pusty)

w parametrze przedziały postępujemy bardzo podobnie tylko sprawdzamy, kiedy nie występuje dany argument

=JEŻELI($A$2:$A$21<>$E2;WIERSZ($A$2:$A$21))

Prowadzi to do tego, że funkcja CZĘSTOŚĆ buduje różne przedziały, w których zliczana jest wartość wystąpień pod rząd danej wartości.

=CZĘSTOŚĆ(JEŻELI($A$2:$A$21=$E2;WIERSZ($A$2:$A$21));JEŻELI($A$2:$A$21<>$E2;WIERSZ($A$2:$A$21)))

Teraz wystarczy sprawdzić ile razy powtórzyła się liczba powtórzeń pod rząd, której szukamy, czyli jeśli szukamy powtórzeń wartości 2 razy pod rząd to przyrównujemy wyniku funkcji CZĘSTOŚĆ do dwójki i sumujemy liczbę wystąpień.

=SUMA(–(CZĘSTOŚĆ(JEŻELI($A$2:$A$21=$E2;WIERSZ($A$2:$A$21));JEŻELI($A$2:$A$21<>$E2;WIERSZ($A$2:$A$21)))=F$1))

ponieważ jest to formuła tablicowa potrzebujemy ją zatwierdzić kombinacją klawiszy Ctrl + Shift + Enter

P.S.

Jeśli chcesz dowiedzieć się więcej na temat Excela lub nie wiesz jak coś zrobić to napisz do mnie. Ja w miarę możliwości odpowiem na Twoje pytanie.

Excel i Adam - kontakt

Bezpośredni odnośnik do filmu na youtube — Ile razy pod rząd pojawia się wartość — porada #155

Wypełnij kolumnę wartościami 1 do 1000 — porada #154

Jak wypełnić kolumnę długim ciągiem liczbowym?


Wypełnij kolumnę wartościami 1 do 1000 — porada #154

Wypełnij kolumnę wartościami 1 do 1000 - porada #154

Są różne sposoby by wypełnić komórki serią liczb. Możesz przeciągnąć prawy dolny róg komórki, gdzie masz wstawioną wartość na samą siebie i z podręcznego menu wybrać opcję Seria danych, a następnie odpowiednio wypełnić okienko, które się pojawi.

Jeśli zaczynasz od 1 wiersza wstawić funkcję WIERSZ i w polu nazwy wpisać zakres od pierwszej komórki do ostatniej. Edytować pierwszą komórkę — klawisz F2, a następnie zatwierdzić Ctrl + Enter, formuła wypełni cały zaznaczony obszar.

Możesz jeszcze nacisnąć Ctrl + G napisać do jakiej komórki chcesz przejść zatwierdzić przyciskiem OK jednocześnie przytrzymująć Shift i postąpić identycznie jak powyżej z zaznaczonym obszarem.

P.S.

Jeśli chcesz dowiedzieć się więcej na temat Excela lub nie wiesz jak coś zrobić to napisz do mnie. Ja w miarę możliwości odpowiem na Twoje pytanie.

Excel i Adam - kontakt

Bezpośredni odnośnik do filmu na youtube — Wypełnij kolumnę wartościami 1 do 1000 — porada #154

Zaznaczanie Celu na wykresie — porada #153

Jak zaznaczyć cel na wykresie?


Zaznaczanie Celu na wykresie — porada #153

Zaznaczanie Celu na wykresie - porada #153

Czasami masz potrzebę, żeby na wykresie zaznaczyć cel — np: wartość sprzedaży, do której dążysz. Okazuje się, że jest to bardzo proste.

Załóżmy, że dodajesz wykres kolumnowy. Skrót Alt + F1 pozwoli Ci go wstawić, jako domyślny wykres (chyba, że zmieniłeś typ domyślnego wykresu). Ale jak zaznaczyć cel? Najprościej dodać jeszcze jedną kolumnę do danych, która na każdej pozycji (np: miesiąca) będzie miała tą samą wartość, albo inną jeśli Twój cel się zmienia.

Teraz jak masz stworzony wykres zaznaczasz serię celu (klikając raz na niej), a następnie wybierasz opcję

Narzędzia wykresów — Projektowanie — Zmień typ wykresu

Tam wybierasz wykres liniowy i już masz linię celu, jeśli wszędzie ma tą samą wartość będzie to linia pozioma.

P.S.

Jeśli chcesz dowiedzieć się więcej na temat Excela lub nie wiesz jak coś zrobić to napisz do mnie. Ja w miarę możliwości odpowiem na Twoje pytanie.

Excel i Adam - kontakt

Bezpośredni odnośnik do filmu na youtube — Zaznaczanie Celu na wykresie — porada #153